Bug 42821 - alpha: futex regression bisected
alpha: futex regression bisected
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: Alpha
All Linux
: P1 normal
Assigned To: Richard Henderson
:
Depends on:
Blocks: 42644
  Show dependency treegraph
 
Reported: 2012-02-26 09:31 UTC by Maciej Rutecki
Modified: 2012-03-12 15:49 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.3-rc6
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2012-02-26 09:31:56 UTC
Subject    : alpha: futex regression bisected
Submitter  : Michael Cree <mcree@orcon.net.nz>
Date       : 2012-02-20 8:20
Message-ID : 4F420256.2090600@orcon.net.nz
References : http://marc.info/?l=linux-kernel&m=132972606917069&w=2

This entry is being used for tracking a regression from 3.2. Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 8d7718aa082aaf30a0b4989e1f04858952f941bc
Author: Michel Lespinasse <walken@google.com>
Date:   Thu Mar 10 18:50:58 2011 -0800

    futex: Sanitize futex ops argument types

First-Bad-Commit : 8d7718aa082aaf30a0b4989e1f04858952f941bc
Comment 1 Maciej Rutecki 2012-03-12 15:49:02 UTC
Fixed in 3.3-rc7 by commit 62aca403657fe30e5235c5331e9871e676d9ea0a.

Note You need to log in before you can comment on or make changes to this bug.