Bug 42803 - Atheros AR9285 Wi-Fi adapter not working on HP 630 notebook with Wheezy
Summary: Atheros AR9285 Wi-Fi adapter not working on HP 630 notebook with Wheezy
Status: RESOLVED INSUFFICIENT_DATA
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jonathan Nieder
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-21 09:51 UTC by Gábor Illés
Modified: 2012-08-31 16:05 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.2.5
Tree: Mainline
Regression: No


Attachments
dmesg without loading hp_wmi (56.17 KB, text/plain)
2012-02-22 07:46 UTC, Gábor Illés
Details
acpidump (271.13 KB, text/plain)
2012-02-22 07:47 UTC, Gábor Illés
Details

Description Gábor Illés 2012-02-21 09:51:13 UTC
I have a fresh install of Wheezy on my new laptop, and noticed that my Wi-Fi
adapter doesn't work. I turned on and off several times the wireless switch on
the laptop's keyboard - no effect. Issued rfkill list command shows that the
switch does not do anything: phy0 is soft and hard blocked too at all time (the
hp-wifi Wireless LAN on the other way is stucked soft - yes, hard - no state).
I have Windows installed on a different partition, haven't experienced any
problem with the adapter.

The device is showing at lspci list:
....
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network
Adapter (PCI-Express) (rev 01)
....

and the ath9k module are present:
lsmod:

....
mac80211              183047  1 ath9k
ath9k_common           12682  1 ath9k
ath9k_hw              281405  2 ath9k,ath9k_common
....

I have a wireless usb adapter - SMCWUSB-G type - and with the installation of
the appropriate package (zd1211) from the repo it had worked perfectly -
network manager and all that.


I have this bug reported already to Debian Bug Tracker (#658401)
Comment 1 Jonathan Nieder 2012-02-21 09:54:20 UTC
Thanks.  Please attach "rfkill list" output.
Comment 2 Gábor Illés 2012-02-21 10:01:21 UTC
Here it is. Note, it isn't changing when i use the laptop's wifi switch.

0: hp-wifi: Wireless LAN
	Soft blocked: yes
	Hard blocked: yes
1: hp-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: yes
2: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: yes

Oh, I'd loaded back the hp_wmi.
Comment 3 John W. Linville 2012-02-21 14:06:02 UTC
I'm sorry, but I don't understand -- is hp_wmi loaded or not?  How does the situation change if hp_wmi is (un)loaded?
Comment 4 Gábor Illés 2012-02-21 15:29:47 UTC
I apologize. The hp_wmi was unloaded by the ask of my contact at bugs.debian.org, where has my first report had gone. It was a trial if it would be the source the problem. I assumed (wrongly) that he is still handling the problem - i am not familiar with either bugreport system.

Unload hp_wmi did not solve the problem. My wifi adapter still not working (and as a matter of fact neither the laptop's bluetooth adapter). I reloaded the hp_wifi driver, then i ran rfkill - you saw the result in my previous post.
Comment 5 Jonathan Nieder 2012-02-21 17:10:05 UTC
Debian bug report: http://bugs.debian.org/658401

Kernel is Debian 3.2.4-1, which includes "PCI: Rework ASPM disable code", making it very close to v3.2.5.

Please provide:

 - steps to reproduce, expected result, actual result, and how the
   difference indicates a bug, for concreteness (should be simple in
   this case)
 - which kernel versions you have tested and what happened with each
 - full "dmesg" output from booting and reproducing the bug without
   loading the hp_wmi driver, as an attachment.
 - corresponding "rfkill list" output
 - "acpidump" output, as another attachment
 - any other weird symptoms or observations
 - what kind of debugging you can do (e.g., if someone provides a
   debugging patch, can you test it?)
Comment 6 Gábor Illés 2012-02-22 07:46:41 UTC
Created attachment 72459 [details]
dmesg without loading hp_wmi
Comment 7 Gábor Illés 2012-02-22 07:47:34 UTC
Created attachment 72460 [details]
acpidump
Comment 8 Gábor Illés 2012-02-22 08:02:06 UTC
OK, I try to gather my findings:

(See my first post.)

  I noticed the bug when I used the network manager to add my home wifi.
The network manager showed (in network settings) that the wireless network is not
available. I tried to switch off the "Fly mode" switch there - no effect.
The wifi switch indicator on my laptop's keyboard is always in off state - no matter what.

  I first noticed the bug with kernel Linux 3.1.0-1-amd64. With that kernel
and the 3.2.0-1-amd64, which i use now there was only one difference related to this bug:
  - With the 3.1.0-1-amd64 the "rfkill unblock all" command actually did unblock
the device - at least I was able to change the soft block state with that. The hard block state was remain blocked all the time. No other change happened - the wifi was still unavailable.
  - With 3.2.0-1-amd64 the rfkill unblock does not do anything any more: all the soft and hard state remained blocked - with hp_wmi loaded. If I unload the hp_wmi, the rfkill list changes according as below. rfkill unblock all does not change block state any more.

Hitting the wifi switch on my keyboard does not changes anything at all.


I attached the requested dmesg and acpidump outputs.

Here is the rfkill list output:


$ sudo rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes

As for my bluetooth: it does not work either. Now, when I unloaded the hp_wmi
it's indicator disappeared from the notification area. Before I was able to change it's state at there, but can not make use from it: still did not work.


As for debugging: I never patched any kernel, or any other software. My last kernel build from source was years ago, so I'm a bit rusty about that. But I volunteer to patch a kernel - it's always a first time, eh? :)
Just tell me, which source version I'm suppose to download?
(And some recent howto will be good...)

Thank you.
Comment 9 Gábor Illés 2012-04-06 14:29:39 UTC
Hey Guys!

My wifi card is now working!!!

I tried many times to switch on my wifi in Wheezy: with
my laptop's wifi button (Fn + F12), with the command <rfkill unblock all> - 
nothing helped.

And then I booted my other OS on the same laptop (WinXP) where the wifi card 
works, turned on the wireless, and left that way. Reboot to Wheezy, and
DANG! The wireless card is started working!

I never turn it off again. :)


Just for notice.
Comment 10 Jonathan Nieder 2012-04-06 15:00:38 UTC
Gábor: is this a regression?  If you try a 2.6.32.y kernel from squeeze (it should work fine on a wheezy/sid system) does it reproduce the same problem?
Comment 11 Gábor Illés 2012-04-07 07:31:36 UTC
Could you lend a hand installing that kernel? It isn't in the repo, and I read some frightening experiment about install a 2.6.x kernel on wheezy, and ruin the system in the process...
Comment 12 Scriptiz 2012-04-22 08:55:19 UTC
Same problem with my Atheros AR9285 on Debian Wheezy (testing) with kernel 3.2.0-2-686-pae

I don't know how but it is working fine with other distros like : 
- Fedora 16 and 17 (beta)
- Ubuntu 12.04 LTS (beta)
- Linux Mint 12
Comment 13 Jonathan Nieder 2012-04-22 23:20:57 UTC
Scriptiz: is this a regression?  If you try a 2.6.32.y kernel from squeeze (it
should work fine on a wheezy/sid system) does it reproduce the same problem?

The easiest way I know to install a 2.6.32.y on wheezy/sid is to add

 deb http://ftp.debian.org/debian squeeze-proposed-updates main

to /etc/apt/sources.list, "apt-get update", and then "apt-get install
linux-image-2.6.32-5-686-bigmem".

Note You need to log in before you can comment on or make changes to this bug.