Bug 42795 - Unable to boot with the radeon driver
Summary: Unable to boot with the radeon driver
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 11:37 UTC by Thomas
Modified: 2012-08-30 14:45 UTC (History)
2 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments

Description Thomas 2012-02-18 11:37:54 UTC
I use an radeon HD 4670 graphic card and can't boot with the 3.3-rc3 kernel, while it works fine with 3.2 (3.3-rc1 and 2 not tested).
The system just hangs and shows me the attached screen. MagicSysRQ not working.
Comment 1 Thomas 2012-02-18 11:39:43 UTC
Can't attach the image as it's to big, so: http://img269.imageshack.us/img269/778/dsc01960ko.jpg
Comment 2 Thomas 2012-02-18 14:50:01 UTC
Future testing showed that the error is presented since 3.3-rc1
Comment 3 Thomas 2012-02-20 00:59:11 UTC
Still presented in 3.3-r4.
Comment 4 Alex Deucher 2012-02-20 02:23:05 UTC
Can you bisect?
Comment 5 Thomas 2012-02-20 02:46:09 UTC
Hi Alex,
I'm not that expert, but I think bisect has something to do with git?
I'll try to figure it out for myself, but it would be great if you could give me step-by-step instructions what to do.
Comment 6 Thomas 2012-02-20 02:58:13 UTC
Okay, I found a description here: http://kerneltrap.org/node/11753 and hope that cloning 2.6 is right.

Also, as a sidenode: The cursor (down left side of the screen) blinks for a few seconds while the system still doesn't react to anything and shows the yellow lines before the screen freezes, too.
Comment 7 Thomas 2012-02-20 04:37:49 UTC
I started with

git bisect good v3.2
git bisect bad v3.3-rc1

and every builded kernel had the issue (more or less, at some point near the end the screen just goes to standby instead of freezing, but every time before freezing/going to standby it showed the yellow lines)

So at the end I got this:

a858393b0ce5c330bda466e5ae3a658ca98588ae is the first bad commit
commit a858393b0ce5c330bda466e5ae3a658ca98588ae
Author: Andrei Emeltchenko <andrei.emeltchenko@intel.com>
Date:   Fri Sep 16 16:26:30 2011 +0300

    Bluetooth: EFS: l2cap extended feature mask update
    
    Update L2CAP extended feature mask to reflect recent BT spec.
    
    Signed-off-by: Andrei Emeltchenko <andrei.emeltchenko@intel.com>
    Signed-off-by: Gustavo F. Padovan <padovan@profusion.mobi>

:040000 040000 d7f27c8ba453168696bf5407d9ca06fd370deda4 11d22bb619481167c4133b27fd87e7be3be636af M	include

But how can a bluetooth change cause that? :(
Comment 8 Thomas 2012-02-20 05:17:09 UTC
Okay, I tracked this down more and was able to boot a 3.3-rc4 kernel. The problem was that radeon and uvesa was compiled into the kernel.
Comment 9 Alex Deucher 2012-02-20 15:27:26 UTC
Ok, this bug can be closed then.

Note You need to log in before you can comment on or make changes to this bug.