Bug 42790 - [hybrid] hang at boot
Summary: [hybrid] hang at boot
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 high
Assignee: drivers_video-dri-intel@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-17 09:17 UTC by Eric Valette
Modified: 2012-04-19 12:16 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.
Tree: Mainline
Regression: Yes


Attachments
3.2.5 cold boot (58.92 KB, text/plain)
2012-02-17 09:17 UTC, Eric Valette
Details
3.2.6 warm boot (58.94 KB, text/plain)
2012-02-17 09:25 UTC, Eric Valette
Details

Description Eric Valette 2012-02-17 09:17:19 UTC
Created attachment 72421 [details]
3.2.5 cold boot

This bug happened before but maybe one out of 40 times. Now its systematic I cannot cold boot at all 3.2.6.

I will add the 3.2.5 dmesg and 3.2.6 warm boot dmesg. If its only a display problem I will try also adding 3.2.6 cold boot dmesg.

Its one of those dual grafic card PC but I'm using Intel one by default.
Comment 1 Eric Valette 2012-02-17 09:25:55 UTC
Created attachment 72422 [details]
3.2.6 warm boot
Comment 2 Eric Valette 2012-02-17 09:29:59 UTC
See also bug 17121
Comment 3 Daniel Vetter 2012-02-17 10:19:54 UTC
Slightly more details on what exactly happens would be interesting.
Comment 4 Eric Valette 2012-02-17 10:41:12 UTC
instead of switching to graphical console (penguin and the rectangle described in bug 17121), the screen remains black. No more console output at all. I dunno what happens as I can't see anything.

The machine is not always totally dead as the power button *sometimes* works. I can do acpi shutdwon. Sometimes I have to push it for 5s.

What more details do you want.
Comment 5 Daniel Vetter 2012-02-20 12:01:34 UTC
This is really bad and sounds like a hard-hang.

I presume you've already tried with i915.ko blacklisted (because I don't see any evidence that this hard-hang is due to i915). If not, can you please try this?

If the above works, can you please wire up netconsole and then manually load i915.ko and grab anything showing up over netconsole?

If all this doesn't help, please bisect where this started to be this ugly.
Comment 6 Eric Valette 2012-02-20 20:12:31 UTC
The nvidia card is not active by default and it takes long time before loading nouveau. When it works I can see the nouveau loading.
Comment 7 Jesse Barnes 2012-04-18 21:10:23 UTC
Does this still happen with current kernels?  Like Daniel said, a log from when this happens as well as a register dump might help.
Comment 8 Eric Valette 2012-04-19 09:19:22 UTC
The hang is gone back at normal rate. Using 3.3.2. now. Once every 20 boots I get a black screen and usually I manage to power off using ACPI via the on/off button. Sometimes I need to hard reboot.
Comment 9 Eric Valette 2012-04-19 12:16:52 UTC
As the problem rate is back at normal rate and I have another bug #17121 whixh show either the white rectangle or the black screen, I think this one may be closed.

Note You need to log in before you can comment on or make changes to this bug.