Bug 42780 - freezing while using IPv6, Wireless & NetworkManager
freezing while using IPv6, Wireless & NetworkManager
Status: RESOLVED CODE_FIX
Product: Networking
Classification: Unclassified
Component: IPV6
All Linux
: P1 high
Assigned To: Hideaki YOSHIFUJI
https://bugs.archlinux.org/task/26847
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-16 07:48 UTC by Anderson Medeiros Gomes
Modified: 2012-08-30 14:39 UTC (History)
10 users (show)

See Also:
Kernel Version: 3.1.0 and upper
Tree: Mainline
Regression: No


Attachments
Kernel messages (617.23 KB, text/x-log)
2012-02-16 07:48 UTC, Anderson Medeiros Gomes
Details
failed kernel log in 3.0.21 (15.16 KB, text/x-log)
2012-02-18 10:23 UTC, zhtlancer
Details
dmesg (145.53 KB, text/plain)
2012-03-17 01:46 UTC, Jan Steffens
Details
dmesg on Linux 3.3 (129.92 KB, text/plain)
2012-03-26 15:57 UTC, Anderson Medeiros Gomes
Details

Description Anderson Medeiros Gomes 2012-02-16 07:48:24 UTC
Created attachment 72396 [details]
Kernel messages

Forwarded from https://bugs.archlinux.org/task/26847

-------
Since updating to 3.1 my laptop froze 3 times already. I don't know what is causing it but this time I checked kernel log and there are lots of "INFO: rcu_preempt_state detected stalls on CPUs/tasks:" messages. They start to appear an hour before system freezes. Meanwhile I only noticed that mp3 playback was little choppy.
-------

The bug report in Arch Linux's website isn't mine, but I'm also experimenting the problem.
Comment 1 zhtlancer 2012-02-17 06:51:10 UTC
Well, just FYI, this problem as recently propagated into 3.0.x within the upgrade from 3.0.20 to 3.0.21, the attachment contains my last kernel failure log with 3.0.21 kernel. And as far as I know, the 3.0.20 doesn't have this problem.

Some information that may help:
Distribution: Arch Linux x86_64
Kernel version: 3.0.21
Network environment: wireless ipv4 + ipv6 dual-stack
Network manage helper: NetworkManager

Hope this will be solved soon, thanks~
Comment 2 zhtlancer 2012-02-18 10:23:03 UTC
Created attachment 72434 [details]
failed kernel log in 3.0.21
Comment 3 bbeschow 2012-02-24 11:40:48 UTC
I confirm this bug for 3.0.22 (package linux-lts-3.0.22 in Archlinux).
Comment 4 zhtlancer 2012-02-24 13:38:09 UTC
I've taken a glimpse at the commits between 3.0.20 and 3.0.21, and I think the problem was introduced by commit 8a533666d1591cf4ea596c6bd710e2fe682cb56a, cause there are some modifications on tcp/ip protocol stack, and also there are some code related with RCU.

Hope this will help~
Comment 5 Ivan daou 2012-03-10 17:43:03 UTC
Same here, a lot of rcu_prempt messages:

Mar  4 09:50:07 ivanoff kernel: INFO: rcu_preempt detected stalls on CPUs/tasks: {} (detected by 2, t=780130 jiffies) 
Mar  4 09:50:07 ivanoff kernel: INFO: Stall ended before state dump start 
Mar  4 09:53:07 ivanoff kernel: INFO: rcu_preempt detected stalls on CPUs/tasks: {} (detected by 3, t=960162 jiffies) 
Mar  4 09:53:07 ivanoff kernel: INFO: Stall ended before state dump start 
Mar  4 09:56:07 ivanoff kernel: INFO: rcu_preempt detected stalls on CPUs/tasks: {} (detected by 2, t=1140194 jiffies) 
Mar  4 09:56:07 ivanoff kernel: INFO: Stall ended before state dump start 

Gentoo, kernel 3.2.1-gentoo-r2 (I know it is not a totally unmodified kernel but same than the other)

that totally disappeared when I modified modprobe.conf with
alias net-pf-10 off # IPv6 
There is something going on with ipv6, I would say
cheers.
Comment 6 Jan Steffens 2012-03-17 01:46:46 UTC
Created attachment 72632 [details]
dmesg 

Stalls again using 3.2.10. The workaround of having NM ignore IPv6 didn't work this time.

Seems I can reproduce it quite reliably by starting a bittorrent client.

dmesg full of backtraces attached.
Comment 7 Anderson Medeiros Gomes 2012-03-26 15:57:41 UTC
Created attachment 72715 [details]
dmesg on Linux 3.3

Tainted kernel, sorry.
Comment 8 Chris Lawrence 2012-03-28 11:50:41 UTC
Fix appears to be here: http://patchwork.ozlabs.org/patch/149020/

Note You need to log in before you can comment on or make changes to this bug.