Bug 42777 - [PATCH]Screen brightness adjust hotkeys don't work with an Acer 5755G laptop
[PATCH]Screen brightness adjust hotkeys don't work with an Acer 5755G laptop
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 normal
Assigned To: drivers_platform@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-15 19:41 UTC by Adam Niedling
Modified: 2015-09-29 20:44 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.3.0-030300rc3-generic
Tree: Mainline
Regression: No


Attachments
dmesg (53.38 KB, text/plain)
2012-02-15 19:41 UTC, Adam Niedling
Details
sudo lspci -vvnn (36.76 KB, text/plain)
2012-02-15 19:42 UTC, Adam Niedling
Details
acpidump.dat (299.85 KB, application/octet-stream)
2012-03-15 11:06 UTC, Adam Niedling
Details
dmidecode.log (14.36 KB, text/x-log)
2012-03-15 11:07 UTC, Adam Niedling
Details
0001-acer-wmi-add-acer-5755G-to-video-backlight-vendor-m.patch (1.18 KB, patch)
2012-07-24 02:11 UTC, Lee, Chun-Yi
Details | Diff
0001-acer-wmi-add-quirk-table-for-video-backlight-vendor.patch (3.18 KB, patch)
2012-07-24 03:17 UTC, Lee, Chun-Yi
Details | Diff

Description Adam Niedling 2012-02-15 19:41:03 UTC
Created attachment 72389 [details]
dmesg

I'm using Ubuntu 11.10 x64. When I press fn+left/right arrow keys the brightness of the screen doesn't change even though the bar appears on the top right corner correctly (This is Ubuntu's way of indicating the change of screen brightness). This laptop has two video cards: nVidia 540M and an integrated Intel HD Graphics 3000. Normally the nVidia card is switched off by Bumblebee so only the Intel one is running.
Comment 1 Adam Niedling 2012-02-15 19:42:59 UTC
Created attachment 72390 [details]
sudo lspci -vvnn
Comment 2 Adam Niedling 2012-02-15 19:45:13 UTC
The original bug report at Launchpad:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/925690 (no additional information over there)
Comment 3 Adam Niedling 2012-02-15 20:27:39 UTC
I was wrong, there are many attachments that can be found at the original report. Those might be helpful, sorry.
Comment 4 Lee, Chun-Yi 2012-03-15 09:41:44 UTC
Hi Adam, 

Please kindly provide your acpidump and dmidecode log:

 #acpidump > acpidump.dat
 #dmidecode > dmidecode.log

Thanks
Comment 5 Adam Niedling 2012-03-15 11:06:58 UTC
Created attachment 72592 [details]
acpidump.dat
Comment 6 Adam Niedling 2012-03-15 11:07:36 UTC
Created attachment 72593 [details]
dmidecode.log
Comment 7 Adam Niedling 2012-03-15 11:09:14 UTC
Hi Chun-Yi!

Certainly, please find them attached!

Thanks
Comment 8 Lee, Chun-Yi 2012-04-19 03:48:38 UTC
(In reply to comment #7)
> Hi Chun-Yi!
> 
> Certainly, please find them attached!
> 
> Thanks

Please try 'acpi_backlight=vendor' kernel parameter, put it to /boot/grub/menu.lst.
Comment 9 Adam Niedling 2012-04-30 09:48:55 UTC
Adding acpi_backlight=vendor as a kernel parameter fixed this issue, now I can adjust the brightness of the screen. However after adding it my system (Ubuntu 12.04 x64) does not always boot up in full graphics mode, only in limited mode or even in command line mode. So it needs some restarting from time to time. 

I did it like this:
vi /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
sudo update-grub

My question is: if this kernel parameter fixes this issue then do you consider this bug fixed or do you still think it needs fixing?

Thanks.
Comment 10 Lee, Chun-Yi 2012-05-05 11:35:20 UTC
(In reply to comment #9)
> Adding acpi_backlight=vendor as a kernel parameter fixed this issue, now I can
> adjust the brightness of the screen. However after adding it my system (Ubuntu
> 12.04 x64) does not always boot up in full graphics mode, only in limited mode
> or even in command line mode. So it needs some restarting from time to time. 
> 

hm..... if this new issue causes by set to 'vendor' mode, then there have video driver problem on your machine. Please kindly paste the the result:
 # ls -la /sys/class/backlight/

I aware there have 2 video chip on your machine, which video chip did you use?

> I did it like this:
> vi /etc/default/grub
> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
> sudo update-grub
> 
> My question is: if this kernel parameter fixes this issue then do you consider
> this bug fixed or do you still think it needs fixing?
> 
> Thanks.

If 'acpi_backlight=vendor' works to you (of course need no side effect), then I will add your machine to a quirk table in acer-wmi driver, set it default to vendor mode.
Comment 11 Adam Niedling 2012-05-06 10:49:57 UTC
The new issue happens when I switch from the laptop's screen and an external monitor and then reboot. After some additional testing I don't think it has anything to do with the backlight parameter because it's also happening without it.

$ ls -la /sys/class/backlight/
összesen 0
drwxr-xr-x  2 root root 0 máj    6  2012 .
drwxr-xr-x 52 root root 0 máj    6  2012 ..
lrwxrwxrwx  1 root root 0 máj    6 12:41 intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-LVDS-1/intel_backlight

I have two video cards as I mentioned in the original post:
$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev ff)

I'm using Bumblebee which means that the Nvidia card is turned off by default but can be turned on anytime for apps that need the extra VGA power.

Let me know if you need more info! Thanks.
Comment 12 Kent Fredic 2012-07-23 17:11:52 UTC
I recently discovered that specifying acpi_osi=Linux on the command line made the backlight buttons magically work, both in X11 and in the VT.

So, this indicates a somewhat "bugged" default acpi table.

Interestingly, it also seems to make the fan management more up-to-what-I-expect. ( Fan works fine without acpi_osi, just seems to run too slowly, but with acpi_osi=Linux it seems to spin up faster more often when needed, instead of letting things cook ).

Kernel: 3.4.4 w/ gentoo patchset.

Lighting seems to appear to be a logarithmic scale of some kind.  0 == can't see a damn thing, and the difference in shades between 100 and 976 are pretty subtle.

cd /sys/class/backlight/intel_backlight
for i in $( seq 0 976 ); do sleep 0.001; echo $i > brightness ; cat actual_brightness ; done

Screen goes black and then fades back to the light.
Comment 13 Kent Fredic 2012-07-23 17:31:52 UTC
"I aware there have 2 video chip on your machine, which video chip did you use?"


In this regard, on this laptop there is no "choice", the Nvidia GPU is completely without an attached display, and there's no way to switch it to your boot display device at all.

All display work is done via the integrated Intel video chip on the i5 chip. And even under windows, the Nvidia gpu works like a headless off-screen render buffer, and copies frames and writes them to the intel gpu to display. ( This is what bumblebee does in Linux )
Comment 14 Lee, Chun-Yi 2012-07-24 02:11:32 UTC
Created attachment 76041 [details]
0001-acer-wmi-add-acer-5755G-to-video-backlight-vendor-m.patch

Let's add Acer Aspire 5755G to quirk table in acer-wmi, first.

The above patch is for v3.5 kernel.
Comment 15 Lee, Chun-Yi 2012-07-24 03:17:40 UTC
Created attachment 76051 [details]
0001-acer-wmi-add-quirk-table-for-video-backlight-vendor.patch

A backport patch for testing on v3.3 kernel.

This patch already include Acer 5755G in quirk table.
Comment 16 Adam Niedling 2013-04-28 16:17:22 UTC
I've upgraded to Ubuntu 13.04 (Kernel 3.8.0-19-generic) and the issue is still present.
Comment 17 Adam Niedling 2013-11-01 17:25:01 UTC
I've upgraded to Ubuntu 13.10 (Kernel 3.11.0-12-generic x64) and the issue is still present.
Comment 18 AnAkkk 2014-01-26 16:00:25 UTC
(In reply to Adam Niedling from comment #17)
> I've upgraded to Ubuntu 13.10 (Kernel 3.11.0-12-generic x64) and the issue
> is still present.

I'd suggest you try the "video.use_native_backlight=1" kernel parameter (Linux 3.13 only), it fixed my backlight issues with an Acer laptop as well.
Comment 19 Adam Niedling 2015-09-29 20:44:28 UTC
It's working in Ubuntu 15.10!

4.2.0-11-generic #13-Ubuntu SMP Mon Sep 21 21:33:10 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Thanks!

Note You need to log in before you can comment on or make changes to this bug.