Bug 4276 - boot hangs when USB mouse plugged in
boot hangs when USB mouse plugged in
Status: REJECTED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 blocking
Assigned To: Alan Stern
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2005-03-02 14:02 UTC by Grześ Andruszkiewicz
Modified: 2005-08-18 21:49 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.8.1, 2.6.9, 2.6.10, 2.6.11
Tree: Mainline
Regression: ---


Attachments
lspci -vvv (on 2.6.7 kernel) (6.85 KB, text/plain)
2005-03-03 11:38 UTC, Grześ Andruszkiewicz
Details
lsusb -vvv (on 2.6.7 kernel) (9.65 KB, text/plain)
2005-03-03 11:44 UTC, Grześ Andruszkiewicz
Details
Config file for my 2.6.11 build (29.20 KB, text/plain)
2005-03-03 11:46 UTC, Grześ Andruszkiewicz
Details
Diagnostic patch for 2.6.11 (644 bytes, patch)
2005-03-04 08:31 UTC, Alan Stern
Details | Diff
More UHCI diagnostics for 2.6.11 (936 bytes, patch)
2005-03-05 14:10 UTC, Alan Stern
Details | Diff

Description Grześ Andruszkiewicz 2005-03-02 14:02:44 UTC
Distribution: Debian, kernel 
Hardware Environment:Gigabyte 845PE P4 Titan Motherboard, Logitech USB mouse
Software Environment:new 2.6 kernels
Problem Description:the kernel boot hangs on uhci_hcd when my mouse is plugged
in. When I boot without the mouse and plug it in afterwards, everything works fine.

Steps to reproduce:boot the kernel with Logitech USB mouse plugged in (?)

I get these logs:
ehci_hcd 0000:00:1d.7: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0 EHCI Controller
PCI: Setting latency timer of device 0000:00:1d.7 to 64
ehci_hcd 0000:00:1d.7: irq 23, pci mem 0xe4000000
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
PCI: cache line size of 128 is not supported by device 0000:00:1d.7
ehci_hcd 0000:00:1d.7: USB 2.0 initialized, EHCI 1.00, driver 10 Dec 2004
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 6 ports detected
USB Universal Host Controller Interface driver v2.2
uhci_hcd 0000:00:1d.0: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI
Controller #1

<*** HERE IT HANGS WITH THE MOUSE PLUGGED IN *****>

PCI: Setting latency timer of device 0000:00:1d.0 to 64
uhci_hcd 0000:00:1d.0: irq 16, io base 0xb800
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
uhci_hcd 0000:00:1d.1: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI
Controller #2
PCI: Setting latency timer of device 0000:00:1d.1 to 64
uhci_hcd 0000:00:1d.1: irq 19, io base 0xb000
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
uhci_hcd 0000:00:1d.2: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI
Controller #3
PCI: Setting latency timer of device 0000:00:1d.2 to 64
uhci_hcd 0000:00:1d.2: irq 18, io base 0xb400
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
Initializing USB Mass Storage driver...
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
Comment 1 Grze&#347; Andruszkiewicz 2005-03-02 14:05:05 UTC
It is my own kernel compilation, didn't try standard Debian kernels.
Comment 2 Nishanth Aravamudan 2005-03-02 22:25:10 UTC
Hi,

.config and lspci -vvv and lsusb -vvv.

Thanks,
Nish
Comment 3 Grze&#347; Andruszkiewicz 2005-03-03 11:38:36 UTC
Created attachment 4651 [details]
lspci -vvv (on 2.6.7 kernel)
Comment 4 Grze&#347; Andruszkiewicz 2005-03-03 11:44:00 UTC
Created attachment 4652 [details]
lsusb -vvv (on 2.6.7 kernel)
Comment 5 Grze&#347; Andruszkiewicz 2005-03-03 11:46:14 UTC
Created attachment 4653 [details]
Config file for my 2.6.11 build
Comment 6 Alan Stern 2005-03-04 08:31:14 UTC
Created attachment 4663 [details]
Diagnostic patch for 2.6.11

It looks like your system is hanging during pci_set_master.  The attached patch
will help test exactly where the hang occurs.
Comment 7 Grze&#347; Andruszkiewicz 2005-03-04 16:38:05 UTC
Last line on the screen was: uhci_hcd 0000:00:1d:0 Before reset
Comment 8 Alan Stern 2005-03-05 14:10:59 UTC
Created attachment 4677 [details]
More UHCI diagnostics for 2.6.11

No "after reset" message?  Try using this patch in addition to the other one. 
Hopefully it will show exactly where in the reset routine things stop working.
Comment 9 Grze&#347; Andruszkiewicz 2005-03-06 03:42:36 UTC
The last log was "D". Before sleep? 
Comment 10 Alan Stern 2005-03-07 07:15:04 UTC
Before a sleep, yes, but while the Global Reset bit is on.  I can't think of any
reason why this should crash your system.  Or why it should crash only during
initial bootup.

As a workaround, you could try making uhci-hcd a module.  It would be
interesting to see if modprobe crashes when the mouse is already plugged in.
Comment 11 Grze&#347; Andruszkiewicz 2005-06-18 10:12:34 UTC
Same bug in 2.6.12 :( 
Comment 12 Alan Stern 2005-06-18 13:19:21 UTC
Did you take my advice to make uhci-hcd a module?  If you then boot with the
mouse plugged in, does the system hang when you load uhci-hcd.ko?
Comment 13 Greg Kroah-Hartman 2005-08-18 21:49:04 UTC
2 months since last response, I'm closing this.

If this is still an issue on 2.6.13-rc6 or greater, please do as Alan asked and
try it with uhci as a module and reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.