Bug 42707 - Hang deconfiguring network interface (in shutdown) on 3.3-rc1
Hang deconfiguring network interface (in shutdown) on 3.3-rc1
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks: 42644
  Show dependency treegraph
 
Reported: 2012-01-31 20:14 UTC by Maciej Rutecki
Modified: 2012-03-05 19:57 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.3-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2012-01-31 20:14:45 UTC
Subject    : Hang deconfiguring network interface (in shutdown) on 3.3-rc1
Submitter  : James Bottomley <James.Bottomley@hansenpartnership.com>
Date       : 2012-01-28 19:56
Message-ID : 1327780565.2924.24.camel@dabdike.int.hansenpartnership.com
References : http://marc.info/?l=linux-kernel&m=132778076214873&w=2

This entry is being used for tracking a regression from 3.2. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Maciej Rutecki 2012-02-28 18:30:16 UTC
Caused by:

commit 92feeabf3f673767c6ee4cfc7fc224098446c1c1
Author: Matt Carlson <mcarlson@broadcom.com>
Date:   Thu Dec 8 14:40:14 2011 +0000

    tg3: Save stats across chip resets

First-Bad-Commit : 92feeabf3f673767c6ee4cfc7fc224098446c1c1
Comment 2 Matt Carlson 2012-03-05 19:15:48 UTC
Fixed by commit ID 65ec698d1368fc64d0b93fb703783d25ec550577, entitled
"tg3: Fix tg3_get_stats64 for 5700 / 5701 devs"

Note You need to log in before you can comment on or make changes to this bug.