Bug 4269 - saa7134-dvb.c does not compile
saa7134-dvb.c does not compile
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: Video(Other)
i386 Linux
: P2 blocking
Assigned To: Adrian Bunk
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 23:28 UTC by Andreas Kuckartz
Modified: 2005-03-07 14:15 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.11-rc5
Tree: Mainline
Regression: ---


Attachments

Description Andreas Kuckartz 2005-02-28 23:28:27 UTC
Distribution: DeMuDi
Hardware Environment: Acer Laptop

I successfully applied the following combination of patches to linux-2.6.10 and
there were no errors when I compiled the result using the default options:

patch-2.6.11-rc5
realtime-preempt-2.6.11-rc4-V0.7.39-02
realtime_lsm.patch

But when I used the options which are used to build the DeMuDi kernel I get this:

drivers/media/video/saa7134/saa7134-dvb.c: In Funktion "dvb_init":
drivers/media/video/saa7134/saa7134-dvb.c:56: error: too few arguments to
function 'videobuf_dvb_register'

I am not sure but maybe that problem is a result of this patch (and a missing
corresponding patch for saa7134-dvb.c):
http://lkml.org/lkml/2005/1/20/96

(I do not need that driver but I still wanted to report the problem.)
Comment 1 Nishanth Aravamudan 2005-03-01 09:43:23 UTC
This is also a problem for cx88-dvb.c. I'll send a mail to the DVB folks to make
sure it is going to be resolved by 2.6.11.

Thanks,
Nish
Comment 2 Nishanth Aravamudan 2005-03-01 10:23:41 UTC
Andreas,

Just heard back from Gerd. The drivers are labelled as BROKEN in Kconfig. Should
be fixed in the 2.6.12 dev cycle.

Thanks,
Nish
Comment 3 Nishanth Aravamudan 2005-03-01 10:25:03 UTC
Sorry, inadvertently closed bug :)
Comment 4 Andreas Kuckartz 2005-03-01 10:31:18 UTC
Thanks for taking care of the problem.

Cheers,
Andreas
Comment 5 Adrian Bunk 2005-03-07 14:15:29 UTC
I'm rejecting this bug, because building with CONFIG_BROKEN=y is not supported
in any way.

Note You need to log in before you can comment on or make changes to this bug.