Bug 42685 - multi-media key "mute" no longer recognized
multi-media key "mute" no longer recognized
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks: 42566
  Show dependency treegraph
 
Reported: 2012-01-29 09:38 UTC by Maciej Rutecki
Modified: 2012-03-06 18:54 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.2
Tree: Mainline
Regression: Yes


Attachments
dmesg 3.1.x (46.21 KB, text/plain)
2012-02-29 10:09 UTC, Toralf Förster
Details
dmesg 3.2.x (47.51 KB, application/octet-stream)
2012-02-29 10:09 UTC, Toralf Förster
Details

Description Maciej Rutecki 2012-01-29 09:38:28 UTC
Subject    : multi-media key "mute" no longer recognized
Submitter  : Toralf Förster <toralf.foerster@gmx.de>
Date       : 2012-01-23 10:52
Message-ID : 201201231152.25344.toralf.foerster@gmx.de
References : http://marc.info/?l=linux-kernel&m=132731613606121&w=2

This entry is being used for tracking a regression from 3.1. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Toralf Förster 2012-02-14 17:37:21 UTC
with xev I get only one small diff related to "serial":

tfoerste@n22 ~ $ tail -v mute-3.*
==> mute-3.0.21 <==
KeyRelease event, serial 33, synthetic NO, window 0x4600001,
root 0xc3, subw 0x0, time 293494, (1260,275), root:(1262,298),
state 0x0, keycode 121 (keysym 0x1008ff12, XF86AudioMute), same_screen YES,
XLookupString gives 0 bytes: 
XFilterEvent returns: False


==> mute-3.2.6 <==
KeyRelease event, serial 32, synthetic NO, window 0x3a00001,
root 0xc3, subw 0x0, time 3424766, (-1217,745), root:(74,768),
state 0x0, keycode 121 (keysym 0x1008ff12, XF86AudioMute), same_screen YES,
XLookupString gives 0 bytes: 
XFilterEvent returns: False
Comment 2 Florian Mickler 2012-02-23 23:03:45 UTC
The key (no pun intended) in getting this solved  is cc'ing the right people.
Comment 3 Dmitry Torokhov 2012-02-24 21:56:19 UTC
Since they keypress is "visible" in X this is certainly not a kernel problem.
Comment 4 Toralf Förster 2012-02-24 22:11:32 UTC
(In reply to comment #3)
> Since they keypress is "visible" in X this is certainly not a kernel problem.

Well, why does booting my Gentoo with any kernel of the 3.0x series doesn't show the problem while booting with 3.1.x or 3.2.x kernel shows it ? Where shoukld I reprot this problem then nstead ?
Comment 5 Dmitry Torokhov 2012-02-24 22:34:59 UTC
Do you know what component reacts to XF86AudioMute on Gentoo? I'd start with your desktop environment.
Comment 6 Florian Mickler 2012-02-28 23:18:32 UTC
Can you bisect between 3.0 and 3.1 to find what change caused this to happen? 
[Did you change your userspace?]
Also can you provide 'good' and 'bad' dmesg? 

Dmitry, please don't close this off, just because the cause is yet unknown. I agree, that it doesn't look like the xev snippet from above gives us any hint on where the problem is, but booting one kernel and getting a working system and booting another kernel and getting a broken system looks like it's the kernels fault.
Comment 7 Toralf Förster 2012-02-29 10:08:53 UTC
I checked again today with kernels 3.0.22, 3.1.10 and 3.2.29-rc1 - the regression is between 3.1.x and 3.2.x, one thing between the dmesg (I'll attach all) is shown here :

tfoerste@n22 ~/tmp $ grep -i -e snd -e sound -e hda dmesg-3.1.10 dmesg-3.2.9-rc1
dmesg-3.1.10:snd_hda_intel 0000:00:1b.0: PCI INT B -> GSI 17 (level, low) -> IRQ 17
dmesg-3.1.10:snd_hda_intel 0000:00:1b.0: irq 47 for MSI/MSI-X
dmesg-3.1.10:snd_hda_intel 0000:00:1b.0: setting latency timer to 64
dmesg-3.1.10:input: HDA Intel Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input6
dmesg-3.1.10:input: HDA Intel Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
dmesg-3.1.10:input: HDA Intel Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8
dmesg-3.1.10:input: HDA Intel Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
dmesg-3.2.9-rc1:snd_hda_intel 0000:00:1b.0: PCI INT B -> GSI 17 (level, low) -> IRQ 17
dmesg-3.2.9-rc1:snd_hda_intel 0000:00:1b.0: irq 46 for MSI/MSI-X
dmesg-3.2.9-rc1:snd_hda_intel 0000:00:1b.0: setting latency timer to 64
dmesg-3.2.9-rc1:hda_codec: CX20561 (Hermosa): BIOS auto-probing.
dmesg-3.2.9-rc1:input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input6
Comment 8 Toralf Förster 2012-02-29 10:09:33 UTC
Created attachment 72496 [details]
dmesg 3.1.x
Comment 9 Toralf Förster 2012-02-29 10:09:55 UTC
Created attachment 72497 [details]
dmesg 3.2.x
Comment 10 Toralf Förster 2012-03-06 12:11:53 UTC
solved by 3868137 at my system (cherry picked and applied on top of 3.2.9).

Note You need to log in before you can comment on or make changes to this bug.