Bug 42684 - FYIO: usb/video 3.2 breaks logitech 9000pro webcam focus control
FYIO: usb/video 3.2 breaks logitech 9000pro webcam focus control
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(Other)
All Linux
: P1 normal
Assigned To: drivers_video-other
:
Depends on:
Blocks: 42566
  Show dependency treegraph
 
Reported: 2012-01-29 09:32 UTC by Maciej Rutecki
Modified: 2012-08-30 14:16 UTC (History)
6 users (show)

See Also:
Kernel Version: 3.2
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2012-01-29 09:32:42 UTC
Subject    : FYIO: usb/video 3.2 breaks logitech 9000pro webcam focus control
Submitter  : M G Berberich <berberic@fmi.uni-passau.de>
Date       : 2012-01-23 21:49
Message-ID : 20120123214934.GA4240@invalid
References : http://marc.info/?l=linux-kernel&m=132735609521443&w=2

This entry is being used for tracking a regression from 3.1. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Greg Kroah-Hartman 2012-02-22 21:04:36 UTC
All USB bugs should be sent to the linux-usb@vger.kernel.org mailing 
list, and not entered into bugzilla.  Please bring this issue up there,
if it is still a problem in the latest kernel release.
Comment 2 Maciej Rutecki 2012-02-23 13:43:30 UTC
This bug is used only for tracking all regressions in _one_ place with reference to report (usually marc.info). You set it as "invalid" because it should be "not entered into bugzilla"?! If true, I think that it is not right, but you decide.

Regards
Comment 3 Greg Kroah-Hartman 2012-02-23 16:33:23 UTC
Oops, sorry, I didn't mean to close this one, my fault.

Reassigning to the correct group, it's not me.
Comment 4 David Mansfield 2012-05-31 13:57:32 UTC
Two problems here, but they seem to be all fixed for me:

1) kernel api for mapping controls changed and userspace had to be updated (fixed in latest libwebcam)

2) missing product_id in XML file for the named webcam (046d:0809) (also fixed in latest libwebcam)

This works for me now in Fedora 17 using their package:

libwebcam-0.2.2-1.fc17.x86_64

and their kernel:

3.3.7-1.fc17.x86_64

Note You need to log in before you can comment on or make changes to this bug.