Bug 42582 - lockdep: INFO: possible circular locking dependency detected
lockdep: INFO: possible circular locking dependency detected
Status: RESOLVED OBSOLETE
Product: File System
Classification: Unclassified
Component: btrfs
All Linux
: P1 normal
Assigned To: fs_btrfs@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-15 15:15 UTC by Patrick
Modified: 2013-04-30 16:51 UTC (History)
1 user (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments

Description Patrick 2012-01-15 15:15:26 UTC
Trying to debug another issue (with a wireless driver), by chance I found this "possible circular locking dependency".

Maybe some dev might want to have a look at those.

https://bugzilla.kernel.org/attachment.cgi?id=72072
https://bugzilla.kernel.org/attachment.cgi?id=72073
Comment 1 Patrick 2012-01-16 11:57:24 UTC
Here is another, I guess mostly identical though, lockdep debug message: https://bugzilla.kernel.org/attachment.cgi?id=72088
Comment 2 Patrick 2012-01-16 12:14:52 UTC
This "bug" is not really affecting me in day to day work (yet?).

It surfaced due to enabling CONFIG_LOCKDEP to debug a wireless driver issue, here: https://bugzilla.kernel.org/show_bug.cgi?id=42576
Comment 3 Josef Bacik 2013-04-30 16:51:35 UTC
Closing, if this is still affecting you on a newer kernel please reopen.

Note You need to log in before you can comment on or make changes to this bug.