Bug 42568 - ThinkPad T520 I/O errors during accessing SD card with internal reader
ThinkPad T520 I/O errors during accessing SD card with internal reader
Status: RESOLVED DUPLICATE of bug 43370
Product: Drivers
Classification: Unclassified
Component: MMC/SD
All Linux
: P1 normal
Assigned To: drivers_mmc-sd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-09 19:00 UTC by Martin Steigerwald
Modified: 2013-01-12 17:26 UTC (History)
1 user (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments
short syslog except with debian kernel 3.1.0-1-amd64 (2.94 KB, text/plain)
2012-01-09 19:00 UTC, Martin Steigerwald
Details
longer syslog excerpt with 3.0.0-2-amd64 (109.09 KB, text/plain)
2012-01-09 19:06 UTC, Martin Steigerwald
Details

Description Martin Steigerwald 2012-01-09 19:00:29 UTC
Created attachment 72056 [details]
short syslog except with debian kernel 3.1.0-1-amd64

I have a ThinkPad T520 with:

martin@merkaba:~> lspci -nn | grep 0d:00.0
0d:00.0 System peripheral [0880]: Ricoh Co Ltd Device [1180:e823] (rev 08)

When inserting a Kingston Ultimate 133x 8 GB SD card and trying to download images via Digikam I get I/O errors like

Nov 14 19:28:49 merkaba kernel: [98277.834867] mmc0: new SDHC card at address 0003
Nov 14 19:28:49 merkaba kernel: [98277.840876] mmcblk0: mmc0:0003 SD8GB 7.41 GiB 
Nov 14 19:28:49 merkaba kernel: [98277.842160]  mmcblk0: p1
Nov 14 19:28:53 merkaba kernel: [98282.326346] FAT-fs (mmcblk0p1): utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
Nov 14 19:28:53 merkaba kernel: [98282.326532] mmcblk0: error -84 sending status command, retrying
Nov 14 19:28:53 merkaba kernel: [98282.326575] mmcblk0: error -84 sending status command, retrying
Nov 14 19:28:53 merkaba kernel: [98282.326616] mmcblk0: error -84 sending status command, aborting
Nov 14 19:28:53 merkaba kernel: [98282.326620] end_request: I/O error, dev mmcblk0, sector 62
Nov 14 19:28:53 merkaba kernel: [98282.326636] FAT-fs (mmcblk0p1): unable to read boot sector
Nov 14 19:28:59 merkaba kernel: [98288.092879] FAT-fs (mmcblk0p1): utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
Nov 14 19:29:35 merkaba kernel: [98323.288231] mmc0: Got data interrupt 0x00200000 even though no data operation was in progress.
Nov 14 19:29:35 merkaba kernel: [98323.288245] sdhci: =========== REGISTER DUMP (mmc0)===========
Nov 14 19:29:35 merkaba kernel: [98323.288257] sdhci: Sys addr: 0xd28ed200 | Version:  0x00000502
Nov 14 19:29:35 merkaba kernel: [98323.288268] sdhci: Blk size: 0x00007200 | Blk cnt:  0x00000001
Nov 14 19:29:35 merkaba kernel: [98323.288279] sdhci: Argument: 0x0000003f | Trn mode: 0x00000003
Nov 14 19:29:35 merkaba kernel: [98323.288290] sdhci: Present:  0x01ef0000 | Host ctl: 0x00000006
Nov 14 19:29:35 merkaba kernel: [98323.288301] sdhci: Power:    0x0000000f | Blk gap:  0x00000000
Nov 14 19:29:35 merkaba kernel: [98323.288311] sdhci: Wake-up:  0x00000000 | Clock:    0x00000107
Nov 14 19:29:35 merkaba kernel: [98323.288322] sdhci: Timeout:  0x0000000b | Int stat: 0x00000000
Nov 14 19:29:35 merkaba kernel: [98323.288332] sdhci: Int enab: 0x02ff008b | Sig enab: 0x02ff008b
Nov 14 19:29:35 merkaba kernel: [98323.288342] sdhci: AC12 err: 0x00000000 | Slot int: 0x00000000
Nov 14 19:29:35 merkaba kernel: [98323.288353] sdhci: Caps:     0x21e8c8b2 | Caps_1:   0x00008073
Nov 14 19:29:35 merkaba kernel: [98323.288364] sdhci: Cmd:      0x0000183a | Max curr: 0x00000040
Nov 14 19:29:35 merkaba kernel: [98323.288371] sdhci: Host ctl2: 0x00000000
Nov 14 19:29:35 merkaba kernel: [98323.288376] sdhci: ===========================================
Nov 14 19:29:35 merkaba kernel: [98323.476134] mmcblk0: error -84 transferring data, sector 63, nr 1, cmd response 0x900, card status 0x0
Nov 14 19:29:35 merkaba kernel: [98323.476428] end_request: I/O error, dev mmcblk0, sector 63
Nov 14 19:29:35 merkaba kernel: [98323.476441] Buffer I/O error on device mmcblk0p1, logical block 1
Nov 14 19:29:35 merkaba kernel: [98323.476450] lost page write due to I/O error on mmcblk0p1
Nov 14 19:31:43 merkaba kernel: [98451.883921] mmc0: card 0003 removed

after a while.

This does not happen when I use an external USB card reader to access this SD card.

I attach some logs with kernel

Linux version 3.1.0-1-amd64 (Debian 3.1.0-1~experimental.1) (waldi@debian.org) (gcc version 4.6.1 

I will attach some more logs with 3.0 in the next step. I also have some older logs but I didn´t note the exact kernel version for these.

I can retry with with 3.2-rc7 or 3.2 final when the debian kernel for it is out.

I just report this know, cause this bug is possibly related to:

Lenovo T420 (Sandy Bridge) Crashes on SD Card gpt partition writing and io errors on insert
https://bugzilla.kernel.org/show_bug.cgi?id=38922

I do think however that I had this with 2.6.39 already as well, but I am not completely sure.

Thanks,
Martin
Comment 1 Martin Steigerwald 2012-01-09 19:06:54 UTC
Created attachment 72057 [details]
longer syslog excerpt with 3.0.0-2-amd64
Comment 2 Alan 2012-06-18 10:37:34 UTC

*** This bug has been marked as a duplicate of bug 43370 ***
Comment 3 Martin Steigerwald 2012-06-18 17:06:19 UTC
Alan, how do you come to think that my report is a duplicate? I see it as related, but in my case the cardreader basically works. Except for the times it doesn´t and returns errors.

SD cards are detected on insertion in my case. Thanks, Martin
Comment 4 Alan 2012-06-18 17:43:59 UTC
Its one of a set of reports on the same controller/laptop all of which appear to be symptoms of the same things
Comment 5 Martin Steigerwald 2013-01-12 17:26:43 UTC
I do not see this anynore on my ThinkPad T520. I just download a ton of photos from a SD card and it just works. Did so before. I think since 3.7 its gone for good. Now I was using 3.8-rc3 + some git.

Note You need to log in before you can comment on or make changes to this bug.