Bug 42512 - [BUG] D state process after unplug and umount usb disk
[BUG] D state process after unplug and umount usb disk
Status: RESOLVED OBSOLETE
Product: File System
Classification: Unclassified
Component: ext3
All Linux
: P1 normal
Assigned To: fs_ext3@kernel-bugs.osdl.org
:
Depends on:
Blocks: 40982
  Show dependency treegraph
 
Reported: 2011-09-07 18:55 UTC by Maciej Rutecki
Modified: 2012-08-30 09:51 UTC (History)
5 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-09-07 18:55:38 UTC
Subject    : [BUG] D state process after unplug and umount usb disk
Submitter  : Dave Young <hidave.darkstar@gmail.com>
Date       : 2011-09-03 10:31
Message-ID : CABqxG0dM27pmAiajtwAFeBVgc=U+2KaaLCYH9wxOdcW=vbku_A@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=131504588401397&w=2

This entry is being used for tracking a regression from 3.0. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Greg Kroah-Hartman 2012-02-22 21:09:15 UTC
All USB bugs should be sent to the linux-usb@vger.kernel.org mailing 
list, and not entered into bugzilla.  Please bring this issue up there,
if it is still a problem in the latest kernel release.
Comment 2 Greg Kroah-Hartman 2012-02-23 21:15:49 UTC
reopening and reassigning to the correct developers.
Comment 3 Jan Kara 2012-02-27 12:04:01 UTC
Hmm, this doesn't look like an ext3 problem. The hanging command is waiting for page to be unlocked which, given it is 'cat' reading a file, is likely because read command interrupted by device unplug was not properly completed... So I'd blame either USB or SCSI layer. Or Greg, what made you think it's an ext3 bug?

Note You need to log in before you can comment on or make changes to this bug.