Bug 42402 - [BUG] Soft-lockup during cpu-hotplug in VFS callpaths
[BUG] Soft-lockup during cpu-hotplug in VFS callpaths
Status: RESOLVED CODE_FIX
Product: File System
Classification: Unclassified
Component: VFS
All Linux
: P1 normal
Assigned To: fs_vfs
:
: 42382 (view as bug list)
Depends on:
Blocks: 36912
  Show dependency treegraph
 
Reported: 2011-09-05 19:17 UTC by Maciej Rutecki
Modified: 2012-08-30 13:37 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.0.1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-09-05 19:17:05 UTC
Subject    : [BUG] Soft-lockup during cpu-hotplug in VFS callpaths
Submitter  : "Srivatsa S. Bhat" <srivatsa.bhat@linux.vnet.ibm.com>
Date       : 2011-08-24 13:56
Message-ID : 4E550057.9070609@linux.vnet.ibm.com
References : http://marc.info/?l=linux-kernel&m=131419353511653&w=2

This entry is being used for tracking a regression from 2.6.39. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Srivatsa S. Bhat 2011-09-06 08:07:52 UTC
*** Bug 42382 has been marked as a duplicate of this bug. ***
Comment 2 Srivatsa S. Bhat 2012-06-05 05:56:08 UTC
This bug was fixed in mainline by the following commit:

commit e30e2fdfe56288576ee9e04dbb06b4bd5f282203
Author: Srivatsa S. Bhat <srivatsa.bhat@linux.vnet.ibm.com>
Date:   Thu Dec 22 02:45:29 2011 +0530

    VFS: Fix race between CPU hotplug and lglocks

Regards,
Srivatsa S. Bhat

Note You need to log in before you can comment on or make changes to this bug.