Bug 41982 - Resume from hibernation sometimes fails unless "Use mwait to offline a processor" patch backed out
Resume from hibernation sometimes fails unless "Use mwait to offline a proces...
Status: RESOLVED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2011-08-29 20:53 UTC by Jonathan Nieder
Modified: 2011-09-01 20:54 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32.45, 2.6.33.18
Tree: Mainline
Regression: Yes


Attachments

Description Jonathan Nieder 2011-08-29 20:53:43 UTC
Subject    : Resume from hibernation sometimes fails
Submitter  : Frédéric Boiteux <fboiteux@calistel.com>
Submitter  : Robert Scott <bugs@humanleg.org.uk>
Date       : 2011-04-11 15:06:06
Message-ID : 20110411110859.6670.40263.reportbug@localhost.localdomain
Reference  : http://thread.gmane.org/gmane.linux.kernel.stable/6341/focus=16950
First-Bad-Commit : 226917b0735f31cf5c704e07fdd590d99bbfae58
First-Bad-Commit : 74a6e0fd8fc216cfa5edcde4bd356a8972cbc74c

This entry is being used for tracking a regression in the 2.6.32.y and 2.6.33.y
longterm trees. Please don't close it until the problem is fixed there.

The triggering commit was intended to improve power consumption: see bug 5471.
2.6.39.y, which includes the same change, works fine.
Comment 1 Greg Kroah-Hartman 2011-08-31 21:40:02 UTC
This fix will be reverted in the next .32 and .33 releases.
Comment 2 Jonathan Nieder 2011-09-01 20:54:32 UTC
Thanks, Greg!  Work still continues to find what upstream fix is needed to get bug 5471 fixed in those trees again (being tracked at http://bugs.debian.org/622259 at the moment).

Note You need to log in before you can comment on or make changes to this bug.