Bug 41792 - hibernation fails on Lenovo T500
hibernation fails on Lenovo T500
Status: CLOSED UNREPRODUCIBLE
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2011-08-26 20:03 UTC by Denis Laxalde
Modified: 2013-03-28 01:47 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.0.0
Tree: Mainline
Regression: No


Attachments
dmesg from hibernation test in 'core' mode (79.00 KB, application/octet-stream)
2011-08-29 20:42 UTC, Denis Laxalde
Details
acpidump output (319.29 KB, application/octet-stream)
2012-01-18 17:53 UTC, Denis Laxalde
Details

Description Denis Laxalde 2011-08-26 20:03:41 UTC
Ref.: Debian bug #623514 - http://bugs.debian.org/623514

Hibernation fails on my Lenovo T500 laptop. More specifically, the machine
does not resume but just starts normally. The following message shows up
before the computer shuts down:

  legacy_resume(): pnp_bus_resume+0x0/0x65 returns -19
  PM: Device 00:0a failed to thaw: error -19

The problem is not new, I never managed to hibernate this machine.

Several (unsuccessful) attempts to narrow the issue have been made on the
Debian side, see the bug log referenced above.
Comment 1 Jonathan Nieder 2011-08-26 22:34:44 UTC
To summarize the Debian report:

$ grep 00:0a dmesg-boot-after-hibernate
[    0.354312] pnp 00:0a: [mem 0xfed40000-0xfed44fff]
[    0.354354] pnp 00:0a: Plug and Play ACPI device, IDs PNP0c31 (active)
[    8.884071] tpm_tis 00:0a: 1.2 TPM (device-id 0x1020, rev-id 6)
[    8.884074] tpm_tis 00:0a: Intel iTPM workaround enabled

Kernel is Debian 3.0.0-1, which is pretty close to v3.0 (and doesn't include most fixes from 3.0-stable). Denis walked through steps 1(a) and (b) of basic-pm-debugging.txt. Out of the 'reboot', 'platform' and 'shutdown' hibernation modes, none worked. Out of the five test modes, all worked fine. Booting with init=/bin/bash did not avoid trouble.  Unloading the tpm and tpm_tis modules before hibernating did not avoid trouble, either. Booting with break=top (which tells initramfs-tools to stop after mounting /sys, /proc, /dev, /dev/pts, and /run), loading the ahci and sd_mod modules, running "swapon /dev/sda5", and then hibernating did not produce a usable hibernation image, either.

The next step according to basic-pm-debugging.txt is to rebuild with a smaller configuration. Any hints for drivers to exclude? Other ideas?

Denis, if you can send a photo of the legacy_resume() message, that would be helpful, too (so we can see how far down it is on the screen and if there is anything above it).
Comment 2 Denis Laxalde 2011-08-29 20:39:09 UTC
(In reply to comment #1)
> Kernel is Debian 3.0.0-1, which is pretty close to v3.0 (and doesn't include
> most fixes from 3.0-stable).

I also tested 3.0.0-3 which shows the same behaviour.

> Denis, if you can send a photo of the legacy_resume() message, that would be
> helpful, too (so we can see how far down it is on the screen and if there is
> anything above it).

There's nothing appearing above this message (the console on which it appears is blank) and there's nothing in logs neither, AFAICT.
Comment 3 Denis Laxalde 2011-08-29 20:42:25 UTC
Created attachment 70822 [details]
dmesg from hibernation test in 'core' mode

Attached ouptut from dmesg after an hibernation test in 'core' mode.

# echo core > /sys/power/pm_test
# echo platform > /sys/power/disk
# echo disk > /sys/power/state
Comment 4 Jonathan Nieder 2011-08-30 03:28:44 UTC
From the successful 'core' hibernation test:

| [   53.729763] legacy_resume(): pnp_bus_resume+0x0/0x6b returns -19
| [   53.729770] PM: Device 00:0a failed to restore: error -19

Thanks, good to know (so looks like these messages are a red herring).

After the hibernate problem is figured out, let's find out what caused
that message and fix it so the next person's not distracted. :)
Comment 5 Jonathan Nieder 2011-08-30 03:31:55 UTC
| ACPI Exception: AE_BAD_PARAMETER, Returned by Handler for [EmbeddedControl] (20110413/evregion-478)
| ACPI Error: Method parse/execution failed [\_SB_.PCI0.LPC_.EC__.LPMD] (Node ffff8800b7efe790), AE_BAD_PARAMETER (20110413/psparse-536)
| ACPI Error: Method parse/execution failed [\_PR_.CPU0._PPC] (Node ffff8800b789f3f8), AE_BAD_PARAMETER (20110413/psparse-536)
| ACPI Error: Method parse/execution failed [\_PR_.CPU1._PPC] (Node ffff8800b789f290), AE_BAD_PARAMETER (20110413/psparse-536)
| ACPI Exception: AE_BAD_PARAMETER, Evaluating _PPC (20110413/processor_perflib-140)

Any idea what these are about?
Comment 6 Zhang Rui 2012-01-18 05:47:50 UTC
Does the problem still exist in the latest kernel?
Comment 7 Denis Laxalde 2012-01-18 15:45:40 UTC
(In reply to comment #6)
> Does the problem still exist in the latest kernel?

Yes.
Comment 8 Jonathan Nieder 2012-01-18 17:10:09 UTC
Thanks, Denis.  What kernel version is that (as reported by "cat /proc/version")?

Please attach "acpidump" output.
Comment 9 Denis Laxalde 2012-01-18 17:53:41 UTC
Created attachment 72113 [details]
acpidump output
Comment 10 Denis Laxalde 2012-01-18 17:54:56 UTC
Linux version 3.2.1, built this morning.
Comment 11 Aaron Lu 2013-03-27 14:22:50 UTC
Hi Denis,

Do you still have this problem? Thanks.
Comment 12 Denis Laxalde 2013-03-27 20:37:27 UTC
(In reply to comment #11)
> Do you still have this problem? Thanks.

Unfortunately, I don't have the computer anymore.
Comment 13 Zhang Rui 2013-03-28 01:47:21 UTC
bug closed.
please feel free to re-open it if anyone can reproduce the problem.

Note You need to log in before you can comment on or make changes to this bug.