Bug 41732 - [radeon] KMS (and X.org) detect wrong outputs
[radeon] KMS (and X.org) detect wrong outputs
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-25 16:53 UTC by Niels Ole Salscheider
Modified: 2012-08-30 22:20 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.1-rc3
Tree: Mainline
Regression: No


Attachments
dmesg output (50.97 KB, application/octet-stream)
2011-08-25 16:59 UTC, Niels Ole Salscheider
Details
xorg log (41.76 KB, application/octet-stream)
2011-08-25 17:01 UTC, Niels Ole Salscheider
Details
dmesg output with drm.debug=4 (136.75 KB, application/octet-stream)
2011-09-02 14:03 UTC, Niels Ole Salscheider
Details
edid for display connected to LVDS (128 bytes, application/octet-stream)
2011-09-02 14:04 UTC, Niels Ole Salscheider
Details
vbios (60.50 KB, application/octet-stream)
2011-09-02 14:31 UTC, Niels Ole Salscheider
Details

Description Niels Ole Salscheider 2011-08-25 16:53:02 UTC
On my notebook, 6520G (mobile A6 APU), KMS detects a screen on VGA-0 although there is no attached. Because of that it chooses a lower resolution than the internal display's native resolution. The selected mode causes the internal display to flicker, though.

In dmesg, I can see the following:

[drm:atom_op_jump] *ERROR* atombios stuck in loop for more than 5secs aborting
[drm:atom_execute_table_locked] *ERROR* atombios stuck executing E3E6 (len 2585, WS 4, PS 4) @ 0xEAD0

Other issues I have with this :
- xrandr reports a size of 0x0 inches for the internal display
- the internal display uses only 6 bit/pixel and there seems to be no way to enable dithering
- the brightness controls do not work although there is a sysfs acpi interface that gets updated
- the display does not come back on after standby

These issues may be unrelated and I will create further bug reports if so, but maybe they give a hint concerning this issue.
Comment 1 Alex Deucher 2011-08-25 16:57:07 UTC
Please attach your xorg log and dmesg output.
Comment 2 Niels Ole Salscheider 2011-08-25 16:59:42 UTC
Created attachment 70172 [details]
dmesg output
Comment 3 Niels Ole Salscheider 2011-08-25 17:01:00 UTC
Created attachment 70182 [details]
xorg log
Comment 4 Niels Ole Salscheider 2011-08-29 12:44:23 UTC
When I run rmmod radeon and insmod radeon after standby via ssh the screen stays black, too.

It seems that the radeon module cannot find any edid information at all.

Is there anything I can do to debug this further?
Comment 5 Niels Ole Salscheider 2011-09-02 14:03:30 UTC
Created attachment 71332 [details]
dmesg output with drm.debug=4

note: radeon_fp_native_mode gets calld for LVDS although get-edid can find valid edid data for it (see next attachment)
Comment 6 Niels Ole Salscheider 2011-09-02 14:04:51 UTC
Created attachment 71342 [details]
edid for display connected to LVDS
Comment 7 Alex Deucher 2011-09-02 14:24:26 UTC
Please attach a copy of your vbios:

(as root)
(use lspci to get the bus id)
cd /sys/bus/pci/devices/<pci bus id>
echo 1 > rom
cat rom > /tmp/vbios.rom
echo 0 > rom
Comment 8 Niels Ole Salscheider 2011-09-02 14:31:03 UTC
Created attachment 71362 [details]
vbios
Comment 9 Niels Ole Salscheider 2011-09-07 16:12:16 UTC
Additional info: All calls to i2c_transfer in drm_do_probe_ddc_edid fail with return code -6.
Comment 10 Alan 2012-08-30 10:48:35 UTC
Is this problem still seen ?
Comment 11 Niels Ole Salscheider 2012-08-30 22:20:42 UTC
This issue is fixed in recent kernels.

Note You need to log in before you can comment on or make changes to this bug.