Bug 41652 - [PATCH]Brightness control keys not working
[PATCH]Brightness control keys not working
Status: CLOSED INVALID
Product: ACPI
Classification: Unclassified
Component: Power-Other
All Linux
: P1 normal
Assigned To: acpi_power-other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-24 11:00 UTC by Lukasz Olszewski
Modified: 2013-01-28 23:45 UTC (History)
6 users (show)

See Also:
Kernel Version: 3.0 3.2
Tree: Mainline
Regression: No


Attachments
AcpiTables (256.73 KB, text/plain)
2011-08-24 11:01 UTC, Lukasz Olszewski
Details
Lspci (23.15 KB, text/plain)
2011-08-24 11:01 UTC, Lukasz Olszewski
Details
Patch (115.94 KB, text/plain)
2011-08-24 11:09 UTC, Lukasz Olszewski
Details
Patch (115.94 KB, patch)
2011-08-24 11:10 UTC, Lukasz Olszewski
Details | Diff

Description Lukasz Olszewski 2011-08-24 11:00:03 UTC
Sony Vaio F1390x
Brightness controls ( Fn+F5 and Fn+F6) are not working.
Acpi codes for these:
 sony/hotkey SNC 00000001 00000011
 sony/hotkey SNC 00000001 0000003b
 sony/hotkey SNC 00000001 00000010
 sony/hotkey SNC 00000001 0000003b

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-7-generic 3.0.0-7.9
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC275 Analog [ALC275 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lukas 2559 F.... pulseaudio
CRDA: Error: [Errno 2] Nie ma takiego pliku ani katalogu
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xea200000 irq 56'
   Mixer name : 'Realtek ALC275'
   Components : 'HDA:10ec0275,104d4f00,00100005'
   Controls : 19
   Simple ctrls : 11
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xe3080000 irq 17'
   Mixer name : 'Nvidia GPU 14 HDMI/DP'
   Components : 'HDA:10de0014,104d4f00,00100100'
   Controls : 16
   Simple ctrls : 4
Date: Sun Jul 31 22:39:40 2011
HibernationDevice: RESUME=UUID=2ef5145a-b4b5-470b-b7ee-0a3d37d8b5f5
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Sony Corporation VPCF1390X
ProcEnviron:
 PATH=(custom, no user)
 LANG=pl_PL.UTF-8
 SHELL=/usr/bin/zsh
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-7-generic root=UUID=0a9d93d9-414c-4222-9472-a3ee68458db1 ro quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-7-generic N/A
 linux-backports-modules-3.0.0-7-generic N/A
 linux-firmware 1.56
SourcePackage: linux
UpgradeStatus: Upgraded to oneiric on 2011-07-27 (4 days ago)
dmi.bios.date: 10/20/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0190Y9
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0190Y9:bd10/20/2010:svnSonyCorporation:pnVPCF1390X:pvrC607147L:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCF1390X
dmi.product.version: C607147L
dmi.sys.vendor: Sony Corporation
Comment 1 Lukasz Olszewski 2011-08-24 11:01:03 UTC
Created attachment 69882 [details]
AcpiTables
Comment 2 Lukasz Olszewski 2011-08-24 11:01:36 UTC
Created attachment 69892 [details]
Lspci
Comment 3 Lukasz Olszewski 2011-08-24 11:05:57 UTC
Some great work that has been already done: http://code.google.com/p/vaio-f11-linux/w/list?q=label:State-Solution
Comment 4 Lukasz Olszewski 2011-08-24 11:09:27 UTC
Created attachment 69912 [details]
Patch

More info:http://code.google.com/p/vaio-f11-linux/wiki/KernelSupport
Comment 5 Lukasz Olszewski 2011-08-24 11:10:36 UTC
Created attachment 69922 [details]
Patch

More info: http://code.google.com/p/vaio-f11-linux/wiki/KernelSupport
Comment 6 Zhang Rui 2012-01-18 05:37:21 UTC
Matthew,
do you have any update on this bug report? or on the patch in comment #5?
Comment 7 Lukasz Olszewski 2012-01-19 07:25:35 UTC
AFAIK there was no action taken to make this patch part of the kernel. So nothing has changed since I've reported this bug.
Comment 8 Lukasz Olszewski 2012-02-05 21:51:16 UTC
Kernel 3.2 brings no changes to this behavior.
Comment 9 Zhang Rui 2012-02-13 05:11:50 UTC
ping Matthew...
Comment 10 Zhang Rui 2012-05-24 08:07:36 UTC
ping Matthew again... :)
Comment 11 Alan 2012-10-02 17:20:49 UTC
NonfreeKernelModules: nvidia

Note You need to log in before you can comment on or make changes to this bug.