Bug 41592 - Laptop batteries still not detected
Laptop batteries still not detected
Status: CLOSED INSUFFICIENT_DATA
Product: ACPI
Classification: Unclassified
Component: EC
All Linux
: P1 normal
Assigned To: Lan Tianyu
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-23 09:43 UTC by Steve
Modified: 2013-03-28 16:33 UTC (History)
6 users (show)

See Also:
Kernel Version: 3.0.3
Tree: Mainline
Regression: No


Attachments
acpidump (243.10 KB, text/plain)
2011-08-23 09:45 UTC, Steve
Details
dmesg (44.43 KB, text/plain)
2011-08-23 09:45 UTC, Steve
Details
dmidecode (15.28 KB, text/plain)
2011-08-23 09:46 UTC, Steve
Details

Description Steve 2011-08-23 09:43:46 UTC
Many people were hoping bug 15707 would bring resolution, but still no joy.
So here goes again:
For me the laptop is a Toshiba L645. The battery shows as not present in
/proc/acpi/battery/info and the ac adapter status reports either online
or offline but never changes when its plugged or unplugged.
The two workarounds are to customize the DSDT, or patch the ec driver as shown
in bug 15707 or even better as in ACPCIA bug 875.
This laptop comes preinstalled with windows 7 and battery/acad works in that.
And to answer a question from bug 15707, windows xp does handle the battery
and ac functions correctly, so windows has been "orphan _reg" capable for a long
time. Hope this helps, any information or testing I'd be more than happy to provide.
Comment 1 Steve 2011-08-23 09:45:05 UTC
Created attachment 69782 [details]
acpidump
Comment 2 Steve 2011-08-23 09:45:50 UTC
Created attachment 69792 [details]
dmesg
Comment 3 Steve 2011-08-23 09:46:50 UTC
Created attachment 69802 [details]
dmidecode
Comment 4 jog 2012-02-09 13:31:16 UTC
I have the similiar issue on a System76 laptop. Everything works fine on 2.6.38 kernel but on 3.0 onwards, AC Adapter unplugged/plugged does not trigger any events. Battery shows as present and does not change state - plugged or unplugged

/sys/devices/LNXSYSTM:00/device:00/PNP0C0A:00/power_supply/BAT0
  vendor:               Clevo CO.
  model:                M740TX
  power supply:         yes
  updated:              Thu Feb  9 08:26:45 2012 (8 seconds ago)
  has history:          yes
  has statistics:       yes
Comment 5 Jay LaCroix 2012-02-21 17:50:34 UTC
I have this same issue on two different laptops, a Latitude E6410 and a Latitude E6420. Both use different Intel chipsets.

Previously, this bug was hit or miss, sometimes it would detect the battery and sometimes not. Now, the problem is much worse, the battery is almost never detected. Now while I'm using my laptops, I have no idea how much battery is left, until it literally starts flashing red on the laptop and then it dies.
Comment 6 Harald Brennich 2012-03-01 20:53:15 UTC
Battery was not detected also on my Toshiba Satellite L755-161 notebook by kernel versions < 3.3. 
The reason was that for the Toshiba ACPI the methods _STA and _BST of device BAT1 (Battery) return the current value only if flag BTIN has been set. This flag is set by method BSTA of device BAT1. BSTA is called by methods _Q09 and _Q20 of device EC (Embedded Control).
Starting with kernel version 3.3.0, this has been fixed. I also have a patch for kernel versions 3.1 and 3.2 (calling BSTA directly or via _Qxx), but I have not submitted it to kernel developers: Why bother when the problem has been fixed?
Comment 7 Jay LaCroix 2012-03-01 22:53:06 UTC
With yours, was your battery detected sometimes? With both of mine, it will sometimes be detected, and sometimes not. It's much worse right now than it was, with my battery being detected literally around 1 in every 15 boots give or take.
Comment 8 Harald Brennich 2012-03-02 10:24:00 UTC
With kernel versions < 3.3 the battery was not detected on boot. The battery was detected and correctly described only after one of the following actions was taken:
1. Open the lid of the notebook
2. Unplug and plug the external power ("AC")
3. Start the system without the battery. Shutdown and start again with battery.
The first two are to be done with a running system, of course. The third only shows the battery for the first start after the shutdown.
These actions trigger the ACPI methods _Q09 or _Q20 and so the battery gets "visible" for methods _STA and _BST.
Comment 9 subb 2012-04-28 06:29:24 UTC
I have a Toshiba L650 laptop with Fedora16 with kernel- 3.3.2-6 . Facing the same issue of batter not being detected at all. Kindly let me know if any more info is needed on this that might help.
Comment 10 Lan Tianyu 2013-02-20 07:35:58 UTC
Hi All:
      Please check whether the following patch fix your issue.
      https://bugzilla.kernel.org/attachment.cgi?id=87901
Comment 11 Lan Tianyu 2013-03-02 04:04:31 UTC
ping...
Comment 12 Lan Tianyu 2013-03-28 16:33:44 UTC
Since no response more than one month, Close the bug.

Note You need to log in before you can comment on or make changes to this bug.