Bug 41352 - VT1708B - No sound in front panel
VT1708B - No sound in front panel
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-18 17:43 UTC by Elder Marco
Modified: 2012-08-30 10:37 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.0.3
Tree: Fedora
Regression: No


Attachments
alsa-info.sh output (24.62 KB, text/plain)
2011-08-18 17:43 UTC, Elder Marco
Details
alsamixer -c0 (80.62 KB, image/png)
2011-08-18 20:03 UTC, Elder Marco
Details

Description Elder Marco 2011-08-18 17:43:46 UTC
Created attachment 69282 [details]
alsa-info.sh output

Well, this bug is "old". Initially, I registered the bug here:
https://bugzilla.redhat.com/show_bug.cgi?id=618447

But there is no answers. Same problem with newer kernel versions (ArchLinux - kernel version 3.0.3).

--------------------------------------------------------------------- 
Description of problem:
I can't use my front panel connectors. I have no sound output/input.
In fedora 12 (32 bits) I used to have my headset in front panel and everything
worked just fine. My audio input source is set to front mic and 'Independent
HP' option is set to OFF.

The sound in my back connectors seems fine, my speakers works.
I had the same problem on Ubuntu 10.04 and fixed it by setting the
"Independent" HP with OFF option, but in fedora 13 not working. 


Version-Release number of selected component (if applicable):
kernel 3.0.3

How reproducible:
Always

Steps to Reproduce:
1. Connect speaker/headphone in front of PC
2. Turn on some player (rhythmbox, totem, amarok..)
3. 

Actual results:
No sound in front panel

Expected results:
Sound

Additional info:

I removed package alsa-plugins-pulseaudio and I rebooted my computer. Did not
work.. the problem persists.

# lshw -c multimedia:
  *-multimedia            
       description: Audio device
       product: MCP73 High Definition Audio
       vendor: nVidia Corporation
       physical id: 9
       bus info: pci@0000:00:09.0
       version: a1
       width: 32 bits
       clock: 66MHz
       capabilities: pm msi bus_master cap_list
       configuration: driver=HDA Intel latency=0 maxlatency=5 mingnt=2
       resources: irq:22 memory:feaf8000-feafbfff
--------------------------------------------------------------

# lscpi -v | grep -A7 Audio
00:09.0 Audio device: nVidia Corporation MCP73 High Definition Audio (rev a1)
 Subsystem: Elitegroup Computer Systems Device 2965
 Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
 Memory at feaf8000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: [44] Power Management version 2
 Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel
-------------------------------------------------------------------

# lsmod 
Module                  Size  Used by
fuse                   54749  2 
sunrpc                192013  1 
p4_clockmod             4363  0 
freq_table              3851  1 p4_clockmod
speedstep_lib           4706  1 p4_clockmod
ip6t_REJECT             4055  2 
nf_conntrack_ipv6      17513  2 
ip6table_filter         2743  1 
ip6_tables             16558  1 ip6table_filter
ipv6                  267017  42 ip6t_REJECT,nf_conntrack_ipv6
uinput                  7230  0 
snd_hda_codec_via      53145  1 
snd_hda_intel          24280  6 
snd_hda_codec          73671  2 snd_hda_codec_via,snd_hda_intel
snd_hwdep               6222  1 snd_hda_codec
snd_seq                50941  0 
snd_seq_device          5895  1 snd_seq
snd_pcm                76131  4 snd_hda_intel,snd_hda_codec
ppdev                   8142  0 
parport_pc             20649  0 
microcode              17930  0 
wmi                     6600  0 
parport                30553  2 ppdev,parport_pc
snd_timer              19234  2 snd_seq,snd_pcm
nvidia              10847792  38 
i2c_nforce2             6566  0 
forcedeth              46972  0 
snd                    60573  18
snd_hda_codec_via,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
i2c_core               24507  2 nvidia,i2c_nforce2
soundcore               6198  1 snd
snd_page_alloc          7221  2 snd_hda_intel,snd_pcm
pata_acpi               3251  0 
ata_generic             3323  0 
usb_storage            44536  0 
pata_amd               10842  0
------------------------------------------------------------------------

$ aplay -l 
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: VT1708B Analog [VT1708B Analog]
  Subdevices: 1/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
card 0: NVidia [HDA NVidia], device 1: VT1708B Digital [VT1708B Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
-------------------------------------------------------------------------
Comment 1 Takashi Iwai 2011-08-18 18:06:41 UTC
How is the hardware configuration?  One line-out, one line-in and one mic-in in rear panel, and one HP-out and one mic-in in front panel?

It's possible that your front box is no HD-audio compliant but AC97 one.  (There are often such machines.)  In such a case, the pin-detection doesn't work because of incompatible connection.

Since 3.0 kernel, the driver provides "Dynamic Power-Control" mixer enum.  Turn this off for disabing the power-control per pin-detection.
Comment 2 Elder Marco 2011-08-18 19:02:45 UTC
Hello, thanks for your reply.

In reply to comment #1)
> How is the hardware configuration?  One line-out, one line-in and one mic-in in
> rear panel, and one HP-out and one mic-in in front panel?
> 
Well, for front panel is line-out (green connector) and mic-in (pink connector). 

> It's possible that your front box is no HD-audio compliant but AC97 one. 
> (There are often such machines.)  In such a case, the pin-detection doesn't
> work because of incompatible connection.
> 
> Since 3.0 kernel, the driver provides "Dynamic Power-Control" mixer enum.  Turn
> this off for disabing the power-control per pin-detection.
I'm sorry. How can I do this? Where?

The sound works fine with kernel 2.6.32, 2.6.31, etc.

Thanks again.
Comment 3 Takashi Iwai 2011-08-18 19:28:57 UTC
(In reply to comment #2)
> Hello, thanks for your reply.
> 
> > It's possible that your front box is no HD-audio compliant but AC97 one. 
> > (There are often such machines.)  In such a case, the pin-detection doesn't
> > work because of incompatible connection.
> > 
> > Since 3.0 kernel, the driver provides "Dynamic Power-Control" mixer enum.  Turn
> > this off for disabing the power-control per pin-detection.
> I'm sorry. How can I do this? Where?

Run "alsamixer -c0", choose "Dynamic Power-Control" via left/right key, and change the value by up/down key.
Comment 4 Elder Marco 2011-08-18 20:03:06 UTC
Unfortunately, I can't find this option on fedora 15 (kernel 2.0 aka 2.6.40) or Arch Linux (kernel 3.0.3). Alsamixer version is 1.0.24.1

A screenshot is attached.
Comment 5 Elder Marco 2011-08-18 20:03:49 UTC
Created attachment 69302 [details]
alsamixer -c0
Comment 6 Elder Marco 2011-08-18 20:09:05 UTC
Obs: The option Independent HP is turned off, but doesn't work.
Comment 7 Takashi Iwai 2011-08-19 05:21:35 UTC
Ah, sorry, it's included since 3.1-rc1.  Try 3.1-rc2 kernel or the latest Linus tree.
Comment 8 Elder Marco 2011-08-19 13:38:15 UTC
Thanks.

I'll wait for this release.

Note You need to log in before you can comment on or make changes to this bug.