Bug 41342 - Audio gain is massively higher in kernel 3.1
Audio gain is massively higher in kernel 3.1
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks: 40982
  Show dependency treegraph
 
Reported: 2011-08-18 08:12 UTC by rocko
Modified: 2011-08-24 11:30 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.0-rc2
Tree: Mainline
Regression: Yes


Attachments
alsa-info.txt (33.04 KB, text/plain)
2011-08-18 11:26 UTC, rocko
Details
Fix patch (561 bytes, patch)
2011-08-18 12:19 UTC, Takashi Iwai
Details | Diff

Description rocko 2011-08-18 08:12:58 UTC
The audio volume is much, much louder in 3.1-rc2 and -rc1 compared to kernel 3.0 and earlier for my card:

00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 05)
	Subsystem: Dell Device 050e
	Flags: bus master, fast devsel, latency 0, IRQ 53
	Memory at f1c00000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd-hda-intel


Sound blasts out deafeningly unless I use alsamixer to adjust Master to zero (alsamixer says this is -64dB) and PCM to near to zero (eg a value like 27, ie -29dB).

Note that with kernel 3.0, adjusting PCM in alsamixer does not affect the sound gain, but in 3.1 it (luckily!) does. It's quite difficult to adjust the sound to a non-painful level using gnome-volume control because the gain is biased so high.
Comment 1 Takashi Iwai 2011-08-18 09:39:47 UTC
Please give alsa-info.sh output (run with --no-upload option).
Comment 2 rocko 2011-08-18 11:26:23 UTC
Created attachment 69262 [details]
alsa-info.txt
Comment 3 Takashi Iwai 2011-08-18 12:18:29 UTC
Thanks.  The bug is that Master volume isn't linked with PCM volume, thus Master is just a noop in the new driver.  The 

Try the patch below.
Comment 4 Takashi Iwai 2011-08-18 12:19:10 UTC
Created attachment 69272 [details]
Fix patch
Comment 5 rocko 2011-08-18 14:19:22 UTC
Thanks, that fixes it.
Comment 6 Takashi Iwai 2011-08-18 14:48:33 UTC
OK, the patch is included in sound git tree now.  It'll be merged likely in 3.1-rc3.
Comment 7 Florian Mickler 2011-08-23 20:18:55 UTC
A patch referencing this bug report has been merged in Linux v3.1-rc3:

commit 3fe45aeaf2033c9eaa5028ed5ba68b466008876f
Author: Takashi Iwai <tiwai@suse.de>
Date:   Thu Aug 18 15:13:17 2011 +0200

    ALSA: hda - Add "PCM" volume to vmaster slave list

Note You need to log in before you can comment on or make changes to this bug.