Bug 41252 - Regression in touchpad driver (HP pavilion dv6-3102sg)
Regression in touchpad driver (HP pavilion dv6-3102sg)
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-16 17:32 UTC by Nasenbaer
Modified: 2012-08-30 10:34 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.38 - current
Tree: Mainline
Regression: Yes


Attachments

Description Nasenbaer 2011-08-16 17:32:01 UTC
From the beginning after installing Mageia on my new Notebook (2.6.38 kernel) the right mouse button did not work correctly, neither did "click and drag" work. In the internet I read that this touchpad is a new "clickpad" model and problems are known, but the fix should be integrated in 2.6.38 - as my kernel was a 2.6.38 one, I thought the problem might be distribution specific, but faced the same on ubuntu linux.
After the release of 3.0 kernel I tried that one as well, but the problem was still the same.

However, yesterday I installed OpenSUSE 11.4 to Test that distribution. It contains the 2.6.37.6 kernel and the touchpad works there like a charm (at least as good as in windows). However as soon as I upgraded the kernel to 3.0 the same problems from Mageia and Ubuntu reappeared on OpenSUSE.

MY CONCLUSION:
between 2.6.37.7 and 2.6.38 a patch must have been integrated, that broke my touchpad.

Touchpad information:

69: PS/2 00.0: 10500 PS/2 Mouse
  [Created at input.183]
  Unique ID: AH6Q.Y_f5kDtfqz2
  Hardware Class: mouse
  Model: "SynPS/2 Synaptics TouchPad"
  Vendor: 0x0002 
  Device: 0x0007 "SynPS/2 Synaptics TouchPad"
  Compatible to: int 0x0210 0x0001
  Device File: /dev/input/mice (/dev/input/mouse0)
  Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event1, /dev/input/by-path/platform-i8042-serio-1-event-mouse, /dev/input/by-path/platform-i8042-serio-1-mouse
  Device Number: char 13:63 (char 13:32)
  Driver Info #0:
    Buttons: 1
    Wheels: 0
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=no, avail=yes, need=no, active=unknown
Comment 1 Nasenbaer 2011-08-21 11:42:11 UTC
Comparing the hardware info with the kernel the touchpad works on, the following lines are different there (2.6.37.6):

Device File: /dev/input/mice (/dev/input/mouse1)
Device Files: /dev/input/mice, /dev/input/mouse1, /dev/input/event7, /dev/input/by-path/platform-i8042-serio-1-event-mouse, 

so it's mouse 1 and event7 - no idea if this is of any help
Comment 2 Dmitry Torokhov 2011-08-25 07:39:42 UTC
Is the touchpad recognized as "SynPS/2 Synaptics TouchPad" with 2.6.37? Or is it detected as a mouse?
Comment 3 Nasenbaer 2011-08-25 08:51:10 UTC
with 2.6.37.6 it is recognized as SynPS/2 Synaptics TouchPad". The *only* output differences are the values posted in comment #1 - so it indeed worked as touchpad - features like scrolling at right touchpad border worked as well.
Comment 4 Dmitry Torokhov 2011-08-25 18:02:41 UTC
OK, it looks like clickpad support still hasn't made it into official xf86-input-synaptics driver and adding multifinger support to kernel driver broke SUSE's detection of clickpads (they detect clickpads by having BTN_LEFT capability only, and we started reporting BTN_TOOL_DOUBLETAP). They should switch to checking INPUT_PROP_BUTTONPAD.
Comment 5 Nasenbaer 2011-08-30 09:33:53 UTC
So is there anything I could do to fix this?

As stated before, this is a distribution independent problem - same problem appears on ubuntu, mageia, mandriva (and of course opensuse) and most probably on other distributions as well (can't test every single one ;) ).

So yes I could post this to the suse bug tracker, but this would not solve it for other distributions. So wouldn't it be better to fix this upstream?

Or is the problem based in xf86-input-synaptics drivers rather than the kernel itself? In that case the bug should be reported to them, so they can fix it, right?

Sorry, but I really would like to see this bug fixed (and my touchpad to work) - I just don't see how I could help the best at the moment.
Comment 6 Dmitry Torokhov 2011-08-30 17:57:57 UTC
(In reply to comment #5)
> Or is the problem based in xf86-input-synaptics drivers rather than the kernel
> itself? In that case the bug should be reported to them, so they can fix it,
> right?

Yes, exactly. SUSE has some additional patches to xf86-input-synaptics that they should send upstream (not kernel but xorg guys). They also need to fix their detection of clickpads as newer clickpads are multi-finger capable so they need to check the new INPUT_PROP_BUTTONPAD property.
Comment 7 Nasenbaer 2011-09-06 19:57:20 UTC
Alright :)

I posted your comment and a link to this bug to the fitting bug at xorg bugtracker (it actually already existed there) - https://bugs.freedesktop.org/show_bug.cgi?id=38303

Btw. the corresponding openSuse bug is: https://bugzilla.novell.com/show_bug.cgi?id=698412

Note You need to log in before you can comment on or make changes to this bug.