Bug 41112 - HP EliteBook 8460p - Screen brightness not working
Summary: HP EliteBook 8460p - Screen brightness not working
Status: CLOSED DUPLICATE of bug 40862
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Video (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_power-video
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-14 08:59 UTC by Pali Rohár
Modified: 2012-06-05 03:07 UTC (History)
1 user (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments
acpidump (706.50 KB, application/octet-stream)
2012-01-18 11:50 UTC, Pali Rohár
Details

Description Pali Rohár 2011-08-14 08:59:43 UTC
Setting brightness level on HP EliteBook 8460p is not working. I tried these commans:

# cat /sys/class/backlight/acpi_video0/max_brightness 
20
# cat /sys/class/backlight/acpi_video0/brightness 
20
# echo 0 > /sys/class/backlight/acpi_video0/brightness 
# cat /sys/class/backlight/acpi_video0/brightness 
0
# echo 20 > /sys/class/backlight/acpi_video0/brightness 
# cat /sys/class/backlight/acpi_video0/brightness 
20

It did not show me any error, but screen brightness was not changed. And setting brightness with Fn keys does not working (xev see scancodes, but nothing happened).

When I disabled ACPI (with acpi=off in grub) brightness keys started working, but xev does not see scancodes. And all other Fn keys does not working (when acpi is disabled).

And it is possible to change brightness (with Fn keys) in Grub. But when linux kernel is loaded (with enabled acpi) brightness keys stop working.
Comment 1 Zhang Rui 2012-01-18 05:34:00 UTC
The problem has not been fixed yet, right?

please attach the acpidump output of this laptop.
Comment 2 Pali Rohár 2012-01-18 11:50:58 UTC
Created attachment 72105 [details]
acpidump
Comment 3 Pali Rohár 2012-02-05 12:35:50 UTC
More info is here: http://www.mail-archive.com/platform-driver-x86@vger.kernel.org/msg02862.html
Brightness control maybe need to be implemented in radeon driver...

*** This bug has been marked as a duplicate of bug 40862 ***

Note You need to log in before you can comment on or make changes to this bug.