Bug 4097 - ACPI does not work anymore (AE_AML_NO_OPERAND)
ACPI does not work anymore (AE_AML_NO_OPERAND)
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: ACPICA-Core
i386 Linux
: P2 normal
Assigned To: Robert Moore
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 18:10 UTC by Brice Goglin
Modified: 2006-09-28 13:13 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.11-rc2-mm1
Tree: Mainline
Regression: ---


Attachments
Output of acpidmp (131.48 KB, text/plain)
2005-01-24 18:11 UTC, Brice Goglin
Details
Output of dmesg -s64000 (15.18 KB, text/plain)
2005-01-24 18:12 UTC, Brice Goglin
Details

Description Brice Goglin 2005-01-24 18:10:25 UTC
Distribution: Debian Sarge
Hardware Environment: Compaq Evo N600c
Problem Description:

Following Len Brown's answer to my initial email
http://lkml.org/lkml/2005/1/24/334

There's no more ACPI working on 2.6.11-rc2-mm1.
Reverting the bk-acpi.patch makes it work.
Comment 1 Brice Goglin 2005-01-24 18:11:33 UTC
Created attachment 4459 [details]
Output of acpidmp
Comment 2 Brice Goglin 2005-01-24 18:12:17 UTC
Created attachment 4460 [details]
Output of dmesg -s64000
Comment 3 Robert Moore 2005-01-25 10:36:48 UTC
Looks like a problem with the global lock was introduced in 20050114.  Will 
fix and release immediately.
Comment 5 Brice Goglin 2005-01-26 16:20:48 UTC
Works on top of 2.6.11-rc2
(and also on top of 2.6.11-rc2-mm1 without its bk-acpi.patch).
At least fans, battery and thermal_zone are back.

I still have these on dmesg but I think it's another problem:
Jan 27 01:11:12 localhost kernel: evgpeblk-0275 [08] ev_save_method_info   :
Unknown GPE method type: C13E (name not of form _Lxx or _Exx)
Jan 27 01:11:12 localhost kernel: evgpeblk-0275 [08] ev_save_method_info   :
Unknown GPE method type: C18F (name not of form _Lxx or _Exx)
Jan 27 01:11:12 localhost kernel: evgpeblk-0275 [08] ev_save_method_info   :
Unknown GPE method type: C1DC (name not of form _Lxx or _Exx)
Jan 27 01:11:12 localhost kernel: evgpeblk-0979 [06] ev_create_gpe_block   : GPE
00 to 0F [_GPE] 2 regs on int 0x9
Jan 27 01:11:12 localhost kernel: evgpeblk-0987 [06] ev_create_gpe_block   :
Found 3 Wake, Enabled 1 Runtime GPEs in this block
Jan 27 01:11:12 localhost kernel: evgpeblk-0275 [08] ev_save_method_info   :
Unknown GPE method type: C13E (name not of form _Lxx or _Exx)
Jan 27 01:11:12 localhost kernel: evgpeblk-0275 [08] ev_save_method_info   :
Unknown GPE method type: C18F (name not of form _Lxx or _Exx)
Jan 27 01:11:12 localhost kernel: evgpeblk-0275 [08] ev_save_method_info   :
Unknown GPE method type: C1DC (name not of form _Lxx or _Exx)
Jan 27 01:11:12 localhost kernel: evgpeblk-0979 [06] ev_create_gpe_block   : GPE
10 to 1F [_GPE] 2 regs on int 0x9
Jan 27 01:11:12 localhost kernel: evgpeblk-0987 [06] ev_create_gpe_block   :
Found 2 Wake, Enabled 5 Runtime GPEs in this block

Thanks a lot.

Note You need to log in before you can comment on or make changes to this bug.