Bug 4070 - possible 2.6.8-2.6.9 regression (Random screen dimming/brightening, and fn buttons work in reverse or delayed)
Summary: possible 2.6.8-2.6.9 regression (Random screen dimming/brightening, and fn bu...
Status: REJECTED DUPLICATE of bug 3851
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Video (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Luming Yu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-20 10:23 UTC by Brian Pritchard
Modified: 2005-09-14 02:04 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.10
Tree: Mainline
Regression: ---


Attachments

Description Brian Pritchard 2005-01-20 10:23:42 UTC
Distribution: Debian testing
Hardware Environment: HP Pavilion ZE4610US laptop
Software Environment: vanilla unpatched kernel, using a custom dsdt
Problem Description:
The screen will just dim on its own, and the function buttons seemed to be
delayed so when I try to brighten the screen and it will dim about 5 shades
before it will start to brighten.  This has been happening with 2.6.9 but I
don't know about 2.6.7 or 2.6.8 because I skipped those, but it definitely did
not do it in 2.6.6.  It seems as if it is not using the custom dsdt at times
too, at which time the screen dims normally, I can tell that this is happening
because I fixed the dsdt so that it would not run slow on battery but it will
sometimes get painfully slow(with no system load) just like it was before I
fixed it.  So one would think that the problem is caused by an error in my
custom dsdt but I don't think so because I? using the same dsdt that worked
perfectly with 2.6.6.  Also the battery status gets stuck at some points at the
same time I experience the screen dimming problem.
OK to summarize: kernel seems to use correct dsdt(custom) most of the time, and
this is when I have dimming and battery monitoring problems, at times it seems
to use the wrong(bios provided) dsdt and problems are not present.  So I would
say to me, just use the dsdt that it gets from the bios then problem solved
right?  But, I need to have the slowdown on battery problem fixed otherwise the
laptop is almost unusably slow.  And this sure seems like a bug to me because
this has only happened in the latter kernels.
relevant files: 
http://http80.net/2.6.10.config
http://http80.net/dsdt.dsl
http://http80.net/dsdt-bios.dsl
http://http80.net/dmesg.txt
Comment 1 Len Brown 2005-08-16 15:23:34 UTC
still an issue in 2.6.13?
any difference if the video module is loaded vs. unloaded?
Comment 2 Luming Yu 2005-09-14 02:04:19 UTC
Please try linux-2.6.14-rc1 , or latest patch at bug 3851.  
If it is still a issue, please reopen. 

*** This bug has been marked as a duplicate of 3851 ***

Note You need to log in before you can comment on or make changes to this bug.