Bug 4064 - Timeout during IDE probe
Timeout during IDE probe
Status: REJECTED DUPLICATE of bug 3615
Product: IO/Storage
Classification: Unclassified
Component: IDE
i386 Linux
: P2 normal
Assigned To: Bartlomiej Zolnierkiewicz
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-19 06:19 UTC by Peter Kovář
Modified: 2005-02-08 15:34 UTC (History)
0 users

See Also:
Kernel Version: 2.6.9
Tree: Mainline
Regression: ---


Attachments

Description Peter Kovář 2005-01-19 06:19:55 UTC
Hardware Environment: TOSHIBA notebook based on Intel 82855PM & 82801DBM (ICH4-M)

Problem Description: Wait during boot until timeout occurs while probing for
nonexisting IDE3, IDE4, IDE5

Steps to reproduce:
Recompilation of kernel w/ following modification avoids wait and helped to
speed up boot sequence.

include/asm-i386/ide.h
#define MAX_HWIFS	2
Comment 1 Peter Kovář 2005-01-25 23:35:54 UTC
Maybe it's just on this line of nice HW, but Linux 2.4 as well as FreeBSD 5.3
are booting without nasty wait.
Comment 2 Bartlomiej Zolnierkiewicz 2005-02-08 15:34:08 UTC

*** This bug has been marked as a duplicate of 3615 ***

Note You need to log in before you can comment on or make changes to this bug.