Bug 4046 - atkbd.c: Unknown key released
atkbd.c: Unknown key released
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Input Devices
i386 Linux
: P2 normal
Assigned To: Vojtech Pavlik
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-15 13:08 UTC by Rafal Krypa
Modified: 2007-10-12 04:35 UTC (History)
0 users

See Also:
Kernel Version: 2.6.9
Tree: Mainline
Regression: ---


Attachments
Config for kernel 2.6.10 (29.93 KB, text/plain)
2005-01-15 13:21 UTC, Rafal Krypa
Details

Description Rafal Krypa 2005-01-15 13:08:35 UTC
Distribution: Debian unstable
Hardware Environment: PC (P4 Prescott with HT) with PS/2 keyboard
Software Environment: Problem appears both under XFree86 and under console with
no X running, kernel was compiled with gcc 3.4 (gcc version 3.4.4 20041218
(prerelease) (Debian 3.4.3-7)) and gcc 3.3 (gcc version 3.3.5 (Debian 1:3.3.5-6))
(no difference)
Problem Description: There are few symptomps that I managed to distinguish:
 * after pressing some key I am getting following error message:
   atkbd.c: Unknown key released (translated set 2, code 0xe0 on isa0060/serio0).
   atkbd.c: Use 'setkeycodes e060 <keycode>' to make it known.
   This is easily reproducable by just holding a key for several seconds. It
seems to be related only to some keys - I managed to produce it only with arrow
keys, insert, home, delete, end, pgup/pgdn and additional "windows keys"
 * one of the shift/alt/ctrl keys suddenly gets stuck, not necessairly after
pressing it. It seems to happen after the above symptom. After pressing and
releasing all mentioned keys the stucked key releases.
 * some key presses and releases get lost - if release is lost I have to press
and release the key again to stop it from repeatng - this problem is not related
to any particular keys and happens randomly - no easy method of reproducing

All these problems happen on kernels 2.6.9, 2.6.10 and 2.6.11-rc1-bk3 (vanilla
sources). With older kernel everything worked fine. Adding option
"atkbd.softrepeat=1" to kernel doesn't have any influence.
Comment 1 Rafal Krypa 2005-01-15 13:21:29 UTC
Created attachment 4411 [details]
Config for kernel 2.6.10
Comment 2 Rafal Krypa 2005-02-19 13:15:55 UTC
Under 2.6.11-rc4 problem exists no more.
Comment 3 Daniele C. 2007-10-12 04:35:17 UTC
Cloned into bug #9147

Note You need to log in before you can comment on or make changes to this bug.