Bug 40442 - cpuinfo_max_freq lost 500MHz
Summary: cpuinfo_max_freq lost 500MHz
Status: CLOSED UNREPRODUCIBLE
Alias: None
Product: Power Management
Classification: Unclassified
Component: cpufreq (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks: 36912
  Show dependency tree
 
Reported: 2011-08-02 20:31 UTC by Harald Dunkel
Modified: 2011-09-07 18:34 UTC (History)
4 users (show)

See Also:
Kernel Version: Linux bugs.afaics.de 3.0.0 #2 SMP PREEMPT Tue Aug 2 22:11:04 CEST 2011 i686 GNU/Linux
Tree: Mainline
Regression: Yes


Attachments
config file (111.07 KB, text/plain)
2011-08-02 20:31 UTC, Harald Dunkel
Details
output of dmesg (43.76 KB, text/plain)
2011-08-02 20:34 UTC, Harald Dunkel
Details

Description Harald Dunkel 2011-08-02 20:31:44 UTC
Created attachment 67362 [details]
config file

Running 3.0 my Pentium M lost 500MHz.

"cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq" shows:

1500000

If I move back to 2.6.39.3 then I get the expected 2000000.
Comment 1 Harald Dunkel 2011-08-02 20:34:02 UTC
Created attachment 67372 [details]
output of dmesg
Comment 2 Len Brown 2011-08-27 00:39:39 UTC
> powernow: This module only works with AMD K7 CPUs
> p4-clockmod: Warning: EST-capable CPU detected. The acpi-cpufreq module
> offers voltage scaling in addition to frequency scaling. You should use that
> instead of p4-clockmod, if possible.
ondemand governor failed, too long transition latency of HW, fallback to performance governor
> p4-clockmod: P4/Xeon(TM) CPU On-Demand Clock Modulation available
> cpufreq-nforce2: No nForce2 chipset.
> ondemand governor failed, too long transition latency of HW, fallback to
> performance governor

#
# x86 CPU frequency scaling drivers
#
# CONFIG_X86_PCC_CPUFREQ is not set
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_POWERNOW_K6=m
CONFIG_X86_POWERNOW_K7=m
CONFIG_X86_POWERNOW_K7_ACPI=y
CONFIG_X86_POWERNOW_K8=m
CONFIG_X86_GX_SUSPMOD=m
CONFIG_X86_SPEEDSTEP_CENTRINO=m
CONFIG_X86_SPEEDSTEP_CENTRINO_TABLE=y
CONFIG_X86_SPEEDSTEP_ICH=m
CONFIG_X86_SPEEDSTEP_SMI=m
CONFIG_X86_P4_CLOCKMOD=m
CONFIG_X86_CPUFREQ_NFORCE2=m
CONFIG_X86_LONGRUN=m
CONFIG_X86_LONGHAUL=m
CONFIG_X86_E_POWERSAVER=m

When you build these as modules, your kernel is at the mercy
of the distro's user-space scripts to decide which order to load them.

Do you see a difference with p4-clockmod excluded from your kernel?

CONFIG_X86_P4_CLOCKMOD=n

the output from

grep . /sys/devices/system/cpu/cpu0/cpufreq/*

for the success and failure case
will help show what is happening.
Comment 3 Harald Dunkel 2011-09-07 18:16:44 UTC
Sorry for the delay, but I cannot reproduce this problem anymore. I tried 3.0.0, 3.0.1 and 3.0.4. The config file hasn't changed, of course.
Comment 4 Florian Mickler 2011-09-07 18:34:35 UTC
Ok, shout if it pops up again.

Note You need to log in before you can comment on or make changes to this bug.