Bug 40432 - not working fn keys - toshiba satellite r850-14t
not working fn keys - toshiba satellite r850-14t
Status: RESOLVED WILL_NOT_FIX
Product: Drivers
Classification: Unclassified
Component: Platform_x86
x86-64 Linux
: P1 high
Assigned To: drivers_platform_x86@kernel-bugs.osdl.org
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2011-08-01 21:08 UTC by juliusvonkohout
Modified: 2013-05-11 23:29 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.0
Tree: Mainline
Regression: No


Attachments
dmesg (56.61 KB, application/octet-stream)
2011-08-01 21:31 UTC, juliusvonkohout
Details
acpidump (198.19 KB, application/octet-stream)
2011-08-06 14:22 UTC, juliusvonkohout
Details
debug.patch (550 bytes, patch)
2011-08-08 02:09 UTC, Lan Tianyu
Details | Diff
keyboard layout (288.81 KB, image/jpeg)
2011-08-08 14:10 UTC, juliusvonkohout
Details
all acpi tables (17.72 KB, application/x-gzip)
2011-08-08 17:27 UTC, juliusvonkohout
Details

Description juliusvonkohout 2011-08-01 21:08:48 UTC
linux mint 11 toshiba satellite r850-14t

several fn keys just dont work.
[ 1766.766319] keyboard: can't emulate rawmode for keycode 240
[ 1766.766330] toshiba_acpi: Unknown key 139

furthermore strange lookups.
and as soon as i plug in the power cord i cannot acces any google sites.
really strange
Comment 1 juliusvonkohout 2011-08-01 21:09:52 UTC
btw acpi bios 2.7 latest from toshiba
Comment 2 juliusvonkohout 2011-08-01 21:29:45 UTC
another error toshiba_acpi: Unknown key e00
ACPI Error: [GTF0] Namespace lookup failure, AE_NOT_FOUND (20110413/psargs-359)
[    4.105203] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.PRT0._SDD] (Node ffff880148e47cd0), AE_NOT_FOUND (20110413/psparse-536)

dmesg  attached
Comment 3 juliusvonkohout 2011-08-01 21:31:01 UTC
Created attachment 67332 [details]
dmesg

dmesg
Comment 4 Lan Tianyu 2011-08-06 09:33:15 UTC
Please attach the output of acpidump.
Comment 5 juliusvonkohout 2011-08-06 14:21:16 UTC
the keys issue is maybe related to https://bugzilla.kernel.org/show_bug.cgi?id=14660

attached acpidump.
if someone manage to solve this give me a paypal number and ill submit 10 euro.its not much but im a student.
Comment 6 juliusvonkohout 2011-08-06 14:22:01 UTC
Created attachment 67812 [details]
acpidump
Comment 7 Lan Tianyu 2011-08-07 13:15:48 UTC
Please list the fn keys  and the Unknown key numbers.
ep. key_mute Unknown key 101
Comment 8 juliusvonkohout 2011-08-07 13:44:25 UTC
2.6.38
mouse disable button does not generate anything which is caused bymissing proper synactics driver afaik.
zoom in and out keys dont generate anything
brightness keys work but produce this ACPI: Failed to switch the brightness
switch to external monit works as far as i remember.cannot test it now.
mouse disable button on f9 key does not generate anything
fn+ space (should be a zoom button according to the icon) produce:
keyboard: can't emulate rawmode for keycode 240
keyboard: can't emulate rawmode for keycode 240
toshiba_acpi: Unknown key 139
internet hotkey and another switch to external monitor key above the keyboard just produce the letter x or mod+x


3.0 exactly the same exept for a flicker if i press the external monitor toggle on the keyboard which could be related to better intel igp support in newer kernel.

just tell me what to do and ill do it almost instantly.
Comment 9 Lan Tianyu 2011-08-08 02:07:09 UTC
List those Fn+key that will produce "toshiba_acpi: Unknown key" with the purpose
and the key number.

Apply the follow patch which may fix the fn+space "ZOOM".
Comment 10 Lan Tianyu 2011-08-08 02:09:32 UTC
Created attachment 68022 [details]
debug.patch
Comment 11 juliusvonkohout 2011-08-08 13:20:20 UTC
thank you the patch fixes the error mesage 
(
keyboard: can't emulate rawmode for keycode 240
keyboard: can't emulate rawmode for keycode 240
toshiba_acpi: Unknown key 139
)
for the zoom key.but the key still does not do anything. cant map it as hotkey.
but that could be an userspace problem.ill try to get it mapped.any tips?

when i plug out the power cord those logs appear:
keyboard: can't emulate rawmode for keycode 240
keyboard: can't emulate rawmode for keycode 240
toshiba_acpi: Unknown key e00
Comment 12 juliusvonkohout 2011-08-08 13:57:55 UTC
showkey command gives me the scancodes.
fn+zoomin 418
fn+zoomout 419
fn+spacezoom 420
internet button does not generate anything if i release it but only if i press it:
(
keycode 28 release
keycode125 press
keycode 45 press
keycode 45 release
keycode125 release
) and the button left to it (switch to external monitor) generates the same.

touchpad toggle on keyboard: 148
touchpad toggle above touchpad: nothing
brightnes up 225 (still ACPI: Failed to switch the brightness, but iw works)
brightness down 224 (still ACPI: Failed to switch the brightness, but it works)
fn+ins(scrolllock) 70
fn+home(sysrq) 99
fn+end(prtsc)  99
fn+pageup(break) 119
fn+pagedown(pause)119

ill upload a picture of my keyboard
Comment 13 juliusvonkohout 2011-08-08 14:10:41 UTC
Created attachment 68042 [details]
keyboard layout
Comment 14 Len Brown 2011-08-08 16:30:48 UTC
The initial report is about Fn keys --
which is a platform-specific-driver/input issue,
not an ACPI issue.  So I'm re-categorizing this report.

The messages in comment #2 are a separate issue,
please file that one against ACPI.  When you do,
please attach any dynamic tables you may find in
/sys/firmware/acpi/tables/dynamic,
as GTF0 is not present in the static tables
that you included via acpidump.
Comment 15 juliusvonkohout 2011-08-08 17:27:24 UTC
Created attachment 68062 [details]
all acpi tables

hope it helps.i just uploaded all tables including dynamic ones
Comment 16 juliusvonkohout 2011-08-08 17:31:02 UTC
https://bugzilla.kernel.org/show_bug.cgi?id=40722 is the new bugreport.
Comment 17 juliusvonkohout 2011-08-12 12:49:10 UTC
is there anything else i cant try?or help you in any way?
Comment 18 juliusvonkohout 2012-01-18 16:37:47 UTC
is the patch in mainline now?
Comment 19 juliusvonkohout 2013-05-11 23:29:47 UTC
im marking my bug as will not fix.
crappy toshiba bios....

Note You need to log in before you can comment on or make changes to this bug.