Bug 40352 - Webcam LED on after resume from suspend{to-ram,to-disk}
Webcam LED on after resume from suspend{to-ram,to-disk}
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 low
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2011-07-30 00:13 UTC by Hugo Osvaldo Barrera
Modified: 2012-06-05 04:24 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.0.0
Tree: Mainline
Regression: No


Attachments

Description Hugo Osvaldo Barrera 2011-07-30 00:13:48 UTC
After suspending {to-ram,to-disk} my webcam LED turns on and remains on until I open an application that uses my webcam and close it.  Also, pluging *any* usb device and unplugging it, makes the led get turned off.

I'm not really what relevant information may be useful here.  I only started using suspend/hibernate a few months ago, and it's always happened.

kernels from 2.6.39.1 to 3.0.0 all present this issue.
pm-utils is version 1.4.1

I've seen a similar bug report on Ubuntu's Launchpad, with no aparent solution.
This really makes me unconfortable since I don't know if the webcam is really in use or not.

This is a Compaq Presario C700. I'm not sure how to provide more relevant hardware information.  I'll provide any aditional details you may need (but I'm not sure what those are right now).

If this is the wrong place (Product) to report this, please advise.  Thanks.
Comment 1 Andrew Morton 2011-08-26 22:05:09 UTC
(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Sat, 30 Jul 2011 00:13:49 GMT
bugzilla-daemon@bugzilla.kernel.org wrote:

> https://bugzilla.kernel.org/show_bug.cgi?id=40352
> 
>            Summary: Webcam LED on after resume from
>                     suspend{to-ram,to-disk}
>            Product: Power Management
>            Version: 2.5
>     Kernel Version: 3.0.0
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: low
>           Priority: P1
>          Component: Hibernation/Suspend
>         AssignedTo: power-management_other@kernel-bugs.osdl.org
>         ReportedBy: hugo@osvaldobarrera.com.ar
>         Regression: No
> 
> 
> After suspending {to-ram,to-disk} my webcam LED turns on and remains on until I
> open an application that uses my webcam and close it.  Also, pluging *any* usb
> device and unplugging it, makes the led get turned off.
> 
> I'm not really what relevant information may be useful here.  I only started
> using suspend/hibernate a few months ago, and it's always happened.
> 
> kernels from 2.6.39.1 to 3.0.0 all present this issue.
> pm-utils is version 1.4.1
> 
> I've seen a similar bug report on Ubuntu's Launchpad, with no aparent solution.
> This really makes me unconfortable since I don't know if the webcam is really
> in use or not.
> 
> This is a Compaq Presario C700. I'm not sure how to provide more relevant
> hardware information.  I'll provide any aditional details you may need (but I'm
> not sure what those are right now).
> 
> If this is the wrong place (Product) to report this, please advise.  Thanks.
>
Comment 2 Hugo Osvaldo Barrera 2011-08-26 22:40:54 UTC
On 2011-08-26 19:04, Andrew Morton wrote:
> (switched to email.  Please respond via emailed reply-to-all, not via the
> bugzilla web interface).

Will do.  What aditional info should I provide to help fix this/trace
what this issue is?

Cheers, thanks,
Comment 3 Alan Stern 2011-08-27 02:22:30 UTC
On Fri, 26 Aug 2011, Hugo Osvaldo Barrera wrote:

> Will do.  What aditional info should I provide to help fix this/trace
> what this issue is?

The dmesg log, showing the initial boot-up and the suspend/resume,
would be helpful.

Alan Stern
Comment 4 Zhang Rui 2012-01-18 05:30:34 UTC
It's great that the kernel bugzilla is back.

Hugo,
Can you please verify if the problem still exists in the latest upstream
kernel?
If yes, please provide the info requested in comment #3.
Comment 5 Hugo Osvaldo Barrera 2012-04-26 17:53:09 UTC
I'm sorry for the really (REALLY) late reply.
I've just tried this today with kernel 3.3.3, and the issue seems to be
gone.
When I suspend-to-{ram,disk}, the webcam LED turns on, and when I
resume, it turns off by itself after a few seconds.

Note You need to log in before you can comment on or make changes to this bug.