Bug 40272 - [bisected regression] Partial breakage of forcedeth driver
[bisected regression] Partial breakage of forcedeth driver
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks: 36912
  Show dependency treegraph
 
Reported: 2011-07-28 13:40 UTC by Maciej Rutecki
Modified: 2011-07-28 14:46 UTC (History)
4 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-07-28 13:40:08 UTC
Subject    : [bisected regression] Partial breakage of forcedeth driver
Submitter  : walt <w41ter@gmail.com>
Date       : 2011-07-24 23:10
Message-ID : 4E2CA683.4010005@gmail.com
References : http://marc.info/?l=linux-kernel&m=131154910129151&w=2

This entry is being used for tracking a regression from 2.6.39. Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 3326c784c9f492e988617d93f647ae0cfd4c8d09
Author: Jiri Pirko <jpirko@>
Date:   Wed Jul 20 04:54:38 2011 +0000

    forcedeth: do vlan cleanup
    
    - unify vlan and nonvlan rx path
    - kill np->vlangrp and nv_vlan_rx_register
    - allow to turn on/off rx vlan accel via ethtool (set_features)
    
    Signed-off-by: Jiri Pirko <jpirko@redhat.com>
    Signed-off-by: David S. Miller <davem@davemloft.net>

First-Bad-Commit : 3326c784c9f492e988617d93f647ae0cfd4c8d09
Comment 1 Jiri Pirko 2011-07-28 14:29:02 UTC
http://patchwork.ozlabs.org/patch/106933/

Should hit net-next in any second :)
Comment 2 Maciej Rutecki 2011-07-28 14:46:57 UTC
Closing. Thanks for information.

Note You need to log in before you can comment on or make changes to this bug.