Bug 4015 - activity on touchpad causes AE_TIME error in battery related method execution
Summary: activity on touchpad causes AE_TIME error in battery related method execution
Status: REJECTED DUPLICATE of bug 3851
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Battery (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Luming Yu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-10 05:52 UTC by Gabor Keresztfalvi
Modified: 2005-03-14 19:01 UTC (History)
0 users

See Also:
Kernel Version: 2.6.10
Tree: Mainline
Regression: ---


Attachments
Dmesg output (16.11 KB, text/plain)
2005-01-10 06:04 UTC, Gabor Keresztfalvi
Details
Output of dmidecode (14.13 KB, text/plain)
2005-01-10 06:15 UTC, Gabor Keresztfalvi
Details
Output of acpidmp (63.24 KB, text/plain)
2005-01-10 06:16 UTC, Gabor Keresztfalvi
Details
Output of lspci -vv (10.91 KB, text/plain)
2005-01-10 06:17 UTC, Gabor Keresztfalvi
Details
Contents of /proc/interrupts (584 bytes, text/plain)
2005-01-10 06:19 UTC, Gabor Keresztfalvi
Details
Disassembled DSDT (108.29 KB, text/plain)
2005-01-10 06:22 UTC, Gabor Keresztfalvi
Details

Description Gabor Keresztfalvi 2005-01-10 05:52:32 UTC
Distribution: SuSE Pro. 9.2
Hardware Environment: Fujitsu Siemens Amilo A1640 (Mobile AMD Sempron 2800+),
512MB RAM (with latest BIOS: 1.01c)
Software Environment: console
Problem Description: battery related method executions throw an AE_TIME error,
and battery status couldn't be retrieved, if the touchpad is used during the call.
Steps to reproduce:
Use the touchpad (it's enough to simply touch it, you do not need X for it)
then the kernel will say this if I want to read battery status (eg. with
powersave -b):
[ACPI Debug] String: [0x09] "BST Start"
evregion-0405: *** Error: Handler for [EmbeddedControl] returned AE_TIME
 dswexec-0438 [473] ds_exec_end_op        : [Store]: Could not resolve operands,
AE_TIME
 psparse-1138: *** Error: Method execution failed [\_SB_.PCI0.BAT0._BST] (Node
c1435668), AE_TIME
acpi_battery-0208 [465] acpi_battery_get_statu: Error evaluating _BST
[ACPI Debug] String: [0x03] "BIf"
evregion-0405: *** Error: Handler for [EmbeddedControl] returned AE_TIME
 dswexec-0438 [474] ds_exec_end_op        : [Store]: Could not resolve operands,
AE_TIME
 psparse-1138: *** Error: Method execution failed [\_SB_.PCI0.BAT0._BIF] (Node
c14356e8), AE_TIME
acpi_battery-0147 [466] acpi_battery_get_info : Error evaluating _BIF

If I use an external USB mouse, then everything is fine.

I think it's similar to Bug 1093.
Comment 1 Gabor Keresztfalvi 2005-01-10 06:04:53 UTC
Created attachment 4364 [details]
Dmesg output
Comment 2 Gabor Keresztfalvi 2005-01-10 06:15:25 UTC
Created attachment 4365 [details]
Output of dmidecode
Comment 3 Gabor Keresztfalvi 2005-01-10 06:16:35 UTC
Created attachment 4366 [details]
Output of acpidmp
Comment 4 Gabor Keresztfalvi 2005-01-10 06:17:49 UTC
Created attachment 4367 [details]
Output of lspci -vv
Comment 5 Gabor Keresztfalvi 2005-01-10 06:19:43 UTC
Created attachment 4368 [details]
Contents of /proc/interrupts
Comment 6 Gabor Keresztfalvi 2005-01-10 06:22:18 UTC
Created attachment 4369 [details]
Disassembled DSDT

I don't know whether you need this...
Comment 7 Gabor Keresztfalvi 2005-01-10 06:36:41 UTC
As Luming Yu suggested in Bug 1093 I'll try the patches from Bug 3851...
Comment 8 Gabor Keresztfalvi 2005-01-10 08:49:40 UTC
With the patches from Bug 3851 (the first hunk of ec-1 patch must be slightly
hacked for 2.6.10) I don't get the AE_TIME error anymore. Instead I've got
"psmouse.c: TouchPad at isa0060/serio2/input0 lost sync at byte 1", but only
once yet. So far, so good...

BTW may this bug be related to my PCMCIA problem? I simply can't make the PCMCIA
socket work. Or is it another IRQ configuration problem demanding another bugreport?
Comment 9 Luming Yu 2005-03-14 19:01:01 UTC

*** This bug has been marked as a duplicate of 3851 ***

Note You need to log in before you can comment on or make changes to this bug.