Bug 39812 - HDMI output is green
HDMI output is green
Status: RESOLVED DUPLICATE of bug 25732
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 blocking
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
https://bugs.freedesktop.org/show_bug...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-22 22:57 UTC by Jürg Billeter
Modified: 2011-07-23 08:31 UTC (History)
0 users

See Also:
Kernel Version: 2.6.37, 2.6.38, 3.0
Tree: Mainline
Regression: Yes


Attachments

Description Jürg Billeter 2011-07-22 22:57:25 UTC
Colors on HDMI screen turn green on kernel mode setting, tested with 2.6.37, 2.6.38, and 3.0. It definitely worked fine with 2.6.35 and earlier. It renders the display unusable, it is not just a small color glitch. This might be related to HDMI audio misdetection.

This bug was originally filed in freedesktop.org bugzilla¹ and more information from multiple reports can be found there. Since the issue is a kernel bug and this major regression has still not been addressed after half a year, maybe an entry in the kernel bugzilla will move things forward.

I'm seeing the issue on a G35 mainboard (Asus P5E-VM HDMI) and a Sharp LC-46X20E TV, but it was also reported for a HM55-based laptop. I'd be happy to test patches or provide debug output.

¹ https://bugs.freedesktop.org/show_bug.cgi?id=33760
Comment 1 Jürg Billeter 2011-07-23 08:31:13 UTC

*** This bug has been marked as a duplicate of bug 25732 ***

Note You need to log in before you can comment on or make changes to this bug.