Bug 39672 - [r280] Black screen on PPC with digital monitor on radeon / Cannot find any crtc or sizes
[r280] Black screen on PPC with digital monitor on radeon / Cannot find any c...
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 high
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 36912
  Show dependency treegraph
 
Reported: 2011-07-20 21:29 UTC by Vlado Plaga
Modified: 2011-08-08 08:40 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.0.0-rc6
Tree: Mainline
Regression: Yes


Attachments
syslog from system without video output (48.97 KB, text/plain)
2011-07-20 21:29 UTC, Vlado Plaga
Details
fix (1.04 KB, patch)
2011-07-22 21:59 UTC, Alex Deucher
Details | Diff

Description Vlado Plaga 2011-07-20 21:29:48 UTC
Created attachment 66132 [details]
syslog from system without video output

Testing Kernel 3.0.0 (rc6 from Debian experimental) I encountered a problem with (DVI) display detection - the screen goes blank when trying to activate KMS. From syslog:

[drm:radeon_add_legacy_connector] *ERROR* DVI: Failed to assign ddc bus! Check dmesg for i2c errors.

[drm]   DDC: no ddc bus - possible BIOS bug - please report to xorg-driver-ati@lists.x.org

No connectors reported connected with modes
[drm] Cannot find any crtc or sizes - going 1024x768

To me this looks quite similar to #23222.

With a VGA monitor the screen does not go blank, but I still don't get the login window in KDM (?).

I'm using Ubuntu 11.04 and with a self-compiled 2.6.39-rc7 kernel I have working KMS (even though direct rendering does not work, as reported on https://bugs.freedesktop.org/show_bug.cgi?id=37169 ).
Comment 1 Alex Deucher 2011-07-22 21:59:15 UTC
Created attachment 66382 [details]
fix

This patch should fix the i2c setup.
Comment 2 Vlado Plaga 2011-07-23 17:24:47 UTC
Great, now I'm running Linux 3.0. :-)

And the best thing: it looks like there's also progress regarding the aforementioned bug I reported on freedesktop.org - I'll have to investigate further. This is what glxinfo reports (instead of 'software renderer'):

"OpenGL renderer string: Mesa DRI R200 (RV280 5962) 20090101 PowerPC/Altivec TCL DRI2"
Comment 3 Florian Mickler 2011-08-04 20:49:24 UTC
Patch: https://bugzilla.kernel.org/attachment.cgi?id=66382

Please close this bug if the patch hits Linus tree.
Comment 4 Florian Mickler 2011-08-08 08:20:19 UTC
A patch referencing this bug report has been merged in Linux v3.1-rc1:

commit 6dd666333ddee39903d86f870d5c40d9f100e0cc
Author: Alex Deucher <alexander.deucher@amd.com>
Date:   Sat Jul 23 18:02:04 2011 +0000

    drm/radeon/kms: fix i2c map for rv250/280

Note You need to log in before you can comment on or make changes to this bug.