Bug 3959 - S3 resume: no video - inspiron 500m
S3 resume: no video - inspiron 500m
Status: REJECTED INSUFFICIENT_DATA
Product: Drivers
Classification: Unclassified
Component: Video(Other)
i386 Linux
: P2 normal
Assigned To: Venkatesh Pallipadi
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-28 13:53 UTC by Loic Dachary
Modified: 2006-08-31 12:22 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.9
Tree: Mainline
Regression: ---


Attachments
acpidmp (58.38 KB, application/octet-stream)
2004-12-28 13:55 UTC, Loic Dachary
Details
dmesg (3.78 KB, application/octet-stream)
2004-12-28 13:56 UTC, Loic Dachary
Details
dmidecode (13.41 KB, application/octet-stream)
2004-12-28 13:56 UTC, Loic Dachary
Details
interrupts (565 bytes, application/octet-stream)
2004-12-28 13:57 UTC, Loic Dachary
Details
lspci (9.27 KB, application/octet-stream)
2004-12-28 13:58 UTC, Loic Dachary
Details

Description Loic Dachary 2004-12-28 13:53:30 UTC
Distribution: Debian GNU/Linux unstable
Hardware Environment: inspiron 500m bios A05
Software Environment: acpid
Problem Description: after going to sleep with echo -n mem > /sys/power/state
and then pressing the power-on button, the system seems to come back to life
except for the fact that the screen is black. When I hit the power-on button
again, the
system shutdown properly.

Steps to reproduce: echo -n mem > /sys/power/state and press power on
Comment 1 Loic Dachary 2004-12-28 13:55:26 UTC
Created attachment 4307 [details]
acpidmp
Comment 2 Loic Dachary 2004-12-28 13:56:07 UTC
Created attachment 4308 [details]
dmesg
Comment 3 Loic Dachary 2004-12-28 13:56:55 UTC
Created attachment 4309 [details]
dmidecode
Comment 4 Loic Dachary 2004-12-28 13:57:28 UTC
Created attachment 4310 [details]
interrupts
Comment 5 Loic Dachary 2004-12-28 13:58:01 UTC
Created attachment 4311 [details]
lspci
Comment 6 Venkatesh Pallipadi 2004-12-28 15:45:21 UTC
Can you try various kernel boot options from Documentation/power/video.txt

And also try the vberestore X workaround in bug #3177. With that suspend-
resume should work while X is running.
Comment 7 Len Brown 2006-08-09 20:43:58 UTC
Video restore on resume from S3 is a BIOS or video driver issue,
not an ACPI issue.  Moving to drivers/video.
Comment 8 Adrian Bunk 2006-08-31 12:22:35 UTC
Please reopen this bug if:
- it is still present in kernel 2.6.17 and
- you can provide the requested information.

Note You need to log in before you can comment on or make changes to this bug.