Bug 39582 - NULL dereference in vfs_getattr
NULL dereference in vfs_getattr
Status: RESOLVED OBSOLETE
Product: File System
Classification: Unclassified
Component: VFS
All Linux
: P1 normal
Assigned To: fs_vfs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-19 14:30 UTC by Witold Baryluk
Modified: 2012-08-24 15:32 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.0.0-rc7
Tree: Mainline
Regression: No


Attachments

Description Witold Baryluk 2011-07-19 14:30:40 UTC
System crashed hard when performing cronjob. X server crashed, and also magic sysrq request was not available.

Kernel config attached.

Relevant fragment of kernel log

[40042.408101] BUG: unable to handle kernel NULL pointer dereference at 00000040
[40042.408265] IP: [<c10a4a40>] vfs_getattr+0x10/0x40
[40042.408372] *pdpt = 000000000e080001 *pde = 0000000000000000 
[40042.408492] Oops: 0000 [#1] 
[40042.408553] Modules linked in: vfat fat ebtable_nat ebtables xt_CHECKSUM acpi_cpufreq mperf lib80211_crypt_ccmp uinput nfsd hdaps radeonfb fb_ddc radeon ipw2200 libipw i2c_i801 ttm drm_kms_helper drm i2c_algo_bit cfbfillrect intel_agp cfbcopyarea intel_gtt cfbimgblt agpgart [last unloaded: scsi_wait_scan]
[40042.409189] 
[40042.409224] Pid: 11095, comm: updatedb.mlocat Not tainted 3.0.0-rc7-t43-prod-00125-gf560f66-dirty #5 IBM 2669UYD/2669UYD
[40042.409444] EIP: 0060:[<c10a4a40>] EFLAGS: 00010286 CPU: 0
[40042.409551] EIP is at vfs_getattr+0x10/0x40
[40042.409633] EAX: f5d9c800 EBX: 00000000 ECX: d8e77f64 EDX: ed3b11b8
[40042.409753] ESI: c8b25288 EDI: ffffff9c EBP: 00000000 ESP: d8e77f30
[40042.409874]  DS: 007b ES: 007b FS: 0000 GS: 0033 SS: 0068
[40042.409980] Process updatedb.mlocat (pid: 11095, ti=d8e76000 task=eea107f0 task.ti=d8e76000)
[40042.410138] Stack:
[40042.410179]  d8e77f40 d8e77f64 c10a4e9e d8e77f40 f5d9c800 ed3b11b8 090fc229 bf9e0598
[40042.410359]  bf9e0524 d8e76000 c10a4ed8 00000100 c10a534e 00000200 00000000 0fd00001
[40042.410540]  000081a4 00000001 00000000 00000000 00000000 00000b29 00000000 4e247f4e
[40042.410721] Call Trace:
[40042.410774]  [<c10a4e9e>] ? vfs_fstatat+0x6e/0x90
[40042.410867]  [<c10a4ed8>] ? vfs_lstat+0x18/0x20
[40042.410957]  [<c10a534e>] ? sys_lstat64+0xe/0x30
[40042.411051]  [<c15713d0>] ? sysenter_do_call+0x12/0x26
[40042.411150] Code: 64 b8 01 00 00 00 5b d3 e0 89 42 40 c3 8d b4 26 00 00 00 00 8d bc 27 00 00 00 00 83 ec 08 89 1c 24 89 74 24 04 8b 72 20 8b 5e 0c <8b> 5b 40 85 db 74 11 ff d3 8b 1c 24 8b 74 24 04 83 c4 08 c3 8d 
[40042.411774] EIP: [<c10a4a40>] vfs_getattr+0x10/0x40 SS:ESP 0068:d8e77f30
[40042.411913] CR2: 0000000000000040
[40042.448154] ---[ end trace 7878ca391f369f1e ]---


i386, Debian GNU/Linux unstable, gcc 4.6.1-4, -march=pentium-m. No suspend/resumes was done on this boot.
Comment 1 Witold Baryluk 2011-07-29 12:48:06 UTC
Cannot reproduce anymore. Probably related to late -rc7 problems with dcache code (fixed in 3.0, right?).

Note You need to log in before you can comment on or make changes to this bug.