Bug 39412 - Win Vista and Win2K8 guests' network breaks down
Win Vista and Win2K8 guests' network breaks down
Status: CLOSED UNREPRODUCIBLE
Product: Virtualization
Classification: Unclassified
Component: kvm
All Linux
: P1 high
Assigned To: virtualization_kvm
:
Depends on:
Blocks: 36912
  Show dependency treegraph
 
Reported: 2011-07-15 15:31 UTC by Jay Ren
Modified: 2011-08-29 16:23 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.0.0-rc6+
Tree: Mainline
Regression: Yes


Attachments

Description Jay Ren 2011-07-15 15:31:14 UTC
Win Vista and Win 2K8 guests cannot find NIC driver using latest kvm upstream tree. (I've installed these NIC drivers in the win imgages, and they worked well before.)
Windows XP doesn't have this this issue.
Both UP and SMP guests have the same issue.
Both virtual NIC and VTD NIC have the same issue, but SR-IOV NIC doesn't have this issue.
Linux guest doesn't have this issue.

reproduce steps:
1.install qemu-kvm and kvm(e2dd78cba341fa7f4d2aa2a3f2a5ec48615155ad)
2.create a win2k8 or Vista guest: 
qemu-system-x86_64  -m 1024 -smp 2  -net nic,macaddr=00:16:3e:41:50:cc,model=rtl8139 -net tap,script=/etc/kvm/qemu-ifup -hda /root/win2k8.img
3.In guest, you'll find that NIC driver cannot be available. In device manager, it shows the NIC doesn't have the corresponding driver. And 'ipconfig' command shows nothing.

BTW,
e2dd78cba341fa7f4d2aa2a3f2a5ec48615155ad commit has the issue;
but e62c2ef9d55731476d5783b06c93976c70b96afa commit doesn't have this issue.
Comment 1 Yan Vugenfirer 2011-07-16 12:26:14 UTC
Driver for Realtek nic (rtl8139) is no longer included in inbox drivers starting with Windows Vista.

Either use e1000 driver NIC or it is possible to copy related files from the previous Windows (XP) and use them (inf, sys files).
Comment 2 Jay Ren 2011-07-17 10:39:20 UTC
(In reply to comment #1)
> Driver for Realtek nic (rtl8139) is no longer included in inbox drivers
> starting with Windows Vista.
> 
> Either use e1000 driver NIC or it is possible to copy related files from the
> previous Windows (XP) and use them (inf, sys files).
Guest have driver for the assigned NIC ( If not originally, I installed the driver), but network in guest breaks down. Sorry for unclear description, and I modified the bug title. It shows NIC has driver, but network breaks down, for example guest cannot get IP from the DHCP server. If using kvm.git commit e62c2ef9, it doesn't have this issue. I use the same win2k8 and Vista image in my test.
BTW, even if I use e1000 NIC, Win2k8 and Vista guest's network is bad, while Win7 and Win XP works well.
Comment 3 Jay Ren 2011-07-29 11:16:55 UTC
This bug got fixed and I verified it. It doesn't exist in latest kvm.git tree e72ef590a3ef3047f6ed5bcb8808a9734f6c4b32.
Comment 4 Florian Mickler 2011-08-04 20:41:57 UTC
Please close it, when it hit's Linus tree. In the meantime we leave it as open, so this doesn't get lost. 

Do you have a pointer to the actual commit that fixed it?
Comment 5 Rafael J. Wysocki 2011-08-14 19:13:36 UTC
Has the bug been fixed in the mainline kernel?
Comment 6 Jay Ren 2011-08-16 02:43:02 UTC
This bug has been fixed in master tree of kvm.git
Sorry but I don't think I have time to bisect which commit or patch introduced and fixed this issue very accurately.
From git log of Avi's kvm.git master tree:
------good commit----------
commit e62c2ef9d55731476d5783b06c93976c70b96afa
Merge: 2e0d8e2 ca56a95
Author: Avi Kivity <avi@redhat.com>
Date:   Thu Jun 30 11:45:57 2011 +0300

-------bad commit---------
commit e2dd78cba341fa7f4d2aa2a3f2a5ec48615155ad
Merge: 481ac8d 4dd1b49
Author: Marcelo Tosatti <mtosatti@redhat.com>
Date:   Thu Jul 7 09:29:58 2011 -0300

-----good commit--------(issue has been fixed)
commite72ef590a3ef3047f6ed5bcb8808a9734f6c4b32
Author: Stefan Hajnoczi <stefanha@linux.vnet.ibm.com>
Date:   Fri Jul 22 12:46:53 2011 +0100
Comment 7 Florian Mickler 2011-08-24 12:29:52 UTC
As far as I can see, the master branch of kvm.git is based upon v3.0.
In fact none of the 3 commits mentioned above are contained in Linus tree.

Can you please test Linus tree (i.e the mainline kernel, currently at v3.1-rc3) and verify that it works (or doesn't work)?
Comment 8 Jay Ren 2011-08-29 08:48:53 UTC
I tried this on Linus' linux 3.1.0-rc4 tree and found this bug got fixed.
The commit I tried is below.
commit c6a389f123b9f68d605bb7e0f9b32ec1e3e14132
Author: Linus Torvalds <torvalds@linux-foundation.org>
Date:   Sun Aug 28 21:16:01 2011 -0700
Comment 9 Florian Mickler 2011-08-29 08:53:53 UTC
Thank you. 
[Because we don't exactly know what fixed it, our rule is to close this as unreproducible.]
Comment 10 Rafael J. Wysocki 2011-08-29 16:23:57 UTC
On Monday, August 29, 2011, Ren, Yongjie wrote:
> I've verified this bug in Linus' tree 3.1.0-rc4. It got fixed, so I closed the bug.
> The commit I tried is below.
> commit c6a389f123b9f68d605bb7e0f9b32ec1e3e14132
> Author: Linus Torvalds <torvalds@linux-foundation.org>
> Date:   Sun Aug 28 21:16:01 2011 -0700
> 
> Best Regards,
>      Yongjie Ren  (Jay)
> 
> > -----Original Message-----
> > From: Rafael J. Wysocki [mailto:rjw@sisk.pl]
> > Sent: Monday, August 29, 2011 3:01 AM
> > To: Linux Kernel Mailing List
> > Cc: Kernel Testers List; Maciej Rutecki; Florian Mickler; Avi Kivity; Ren, Yongjie;
> > Marcelo Tosatti; Stefan Hajnoczi
> > Subject: [Bug #39412] Win Vista and Win2K8 guests' network breaks down
> > 
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.39 and 3.0.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.39 and 3.0.  Please verify if it still should
> > be listed and let the tracking team know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=39412
> > Subject		: Win Vista and Win2K8 guests' network breaks down
> > Submitter	: Jay Ren <yongjie.ren@intel.com>
> > Date		: 2011-07-15 15:31 (45 days old)
> > 
> 
>

Note You need to log in before you can comment on or make changes to this bug.