Bug 39342 - [3.0.0-rc6-git7] possible recursive locking at cache_alloc_refill
[3.0.0-rc6-git7] possible recursive locking at cache_alloc_refill
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 36912
  Show dependency treegraph
 
Reported: 2011-07-14 08:07 UTC by Maciej Rutecki
Modified: 2011-08-23 07:43 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.0.0-rc6-git7
Tree: Mainline
Regression: Yes


Attachments
dmesg of the log (80.11 KB, text/plain)
2011-08-23 07:43 UTC, Dheeraj
Details
The respective .config (58.74 KB, text/plain)
2011-08-23 07:43 UTC, Dheeraj
Details

Description Maciej Rutecki 2011-07-14 08:07:01 UTC
Subject    : [3.0.0-rc6-git7] possible recursive locking at cache_alloc_refill
Submitter  : Tetsuo Handa <penguin-kernel@i-love.sakura.ne.jp>
Date       : 2011-07-11 12:37
Message-ID : 201107112137.FAD00545.SHtLOFOJOMFQFV@I-love.SAKURA.ne.jp
References : http://marc.info/?l=linux-kernel&m=131038788902151&w=2

This entry is being used for tracking a regression from 2.6.39. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2011-08-15 08:55:51 UTC
merged in v3.1-rc1:

commit 30765b92ada267c5395fc788623cb15233276f5c
Author: Peter Zijlstra <peterz@infradead.org>
Date:   Thu Jul 28 23:22:56 2011 +0200

    slab, lockdep: Annotate the locks before using them

commit 83835b3d9aec8e9f666d8223d8a386814f756266
Author: Peter Zijlstra <peterz@infradead.org>
Date:   Fri Jul 22 15:26:05 2011 +0200

    slab, lockdep: Annotate slab -> rcu -> debug_object -> slab
Comment 2 Rafael J. Wysocki 2011-08-15 09:25:49 UTC
On Monday, August 15, 2011, Tetsuo Handa wrote:
> Pekka Enberg wrote:
> > Tetsuio, did Peter's commit 30765b9 ("slab, lockdep: Annotate the locks 
> > before using them") and commit 83835b3 ("slab, lockdep: Annotate slab -> 
> > rcu -> debug_object -> slab") in Linus' git fix this for you?
> 
> Yes. Applying these two commits fixes this problem.
Comment 3 Dheeraj 2011-08-23 07:41:04 UTC
(In reply to comment #2)
> On Monday, August 15, 2011, Tetsuo Handa wrote:
> > Pekka Enberg wrote:
> > > Tetsuio, did Peter's commit 30765b9 ("slab, lockdep: Annotate the locks 
> > > before using them") and commit 83835b3 ("slab, lockdep: Annotate slab -> 
> > > rcu -> debug_object -> slab") in Linus' git fix this for you?
> > 
> > Yes. Applying these two commits fixes this problem.

But probably not in all cases.. I have a machine in which 3.1-rc3 still shows
this issue.
Attached are the dmesg/.config

dheeraj
Comment 4 Dheeraj 2011-08-23 07:43:14 UTC
Created attachment 69742 [details]
dmesg of the log
Comment 5 Dheeraj 2011-08-23 07:43:53 UTC
Created attachment 69752 [details]
The respective .config

Note You need to log in before you can comment on or make changes to this bug.