Bug 3919 - SIGFPE in libc6's difftime() when waking up from sleep under zsh
Summary: SIGFPE in libc6's difftime() when waking up from sleep under zsh
Status: REJECTED DUPLICATE of bug 4532
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Shaohua
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-19 06:06 UTC by Lo
Modified: 2005-09-13 21:48 UTC (History)
0 users

See Also:
Kernel Version: 2.6.10-1-686
Tree: Mainline
Regression: ---


Attachments

Description Lo 2004-12-19 06:06:18 UTC
Distribution: Debian/sid
Hardware Environment: Thinkpad T40p 2373-G1G
Software Environment: Debian kernel-image-2.6.8-1-686 2.6.8-10, with cmdline
root=/dev/hda2 ro nolapic 
Problem Description: SIGFPE in libc6's difftime() when waking up from sleep
under zsh

Steps to reproduce:
1. Run as root "gdb zsh"
2. Launch zsh with "run"
3. Type "echo mem > /sys/power/state", system should sleep
4. Press power button or open lid and system should wake up
5. You get a SIGFPE in the difftime() function from libc6.

Sadly, this happens with Debian 2.6.8.1 and 2.6.9 kernels.  I have searched a
while to understand where it comes from and explained the details in the Debian
bug report:
<http://bugs.debian.org/262988>

Let me know if this is insufficient, I'd be glad to complete the informations.
Comment 1 Shaohua 2004-12-19 23:42:50 UTC
Could you please try latest kernel? Does this bug always show or just 
occasionally?
Comment 2 Lo 2004-12-20 02:59:58 UTC
Ok, I'll try 2.6.10-rc3 ASAP if that's the kernel you meant.  I have to mention
that I won't build it with the Debian patches applied, but with the same .config
as far as possible.

Yes, it always happen, especially in 2.6.8.1 and in 2.6.9.
Comment 3 Len Brown 2004-12-22 19:31:44 UTC
Does "date" give the correct answer after resume?
Comment 4 Lo 2004-12-25 01:04:00 UTC
Yes the date is correct:
bee# date                     
Fri Dec 24 19:23:36 CET 2004
bee# echo 3 > /proc/acpi/sleep
zsh: floating point exception  sux -
bee% date
Fri Dec 24 19:23:55 CET 2004

Did you see gdb's output examining the FPU?  Sounds a bit strange to me that the
FPU state seems borken.

I'm trying to bring a 2.6.10-rc3 to work, but I miss some time before my
holidays though.

Merry Christmas!
Comment 5 Lo 2005-01-13 00:07:39 UTC
I confirm this still happens in 2.6.10.
Comment 6 Lo 2005-07-22 05:24:34 UTC
Might be fixed by:
commit 9d9437759eb6fdb68f7b82cbee20b0fb711d9f0d
Author: Nickolai Zeldovich <kolya@MIT.EDU>
Date:   Fri Apr 8 23:37:34 2005 -0400

    [ACPI] S3 resume -- use lgdtl, not lgdt
    
    From: Nickolai Zeldovich <kolya@MIT.EDU>
    Signed-off-by: Len Brown <len.brown@intel.com>

Will confirm when it hits Debian.
Comment 7 Shaohua 2005-09-05 00:00:05 UTC
Could we have an update with latest kernel?
Comment 8 Lo 2005-09-05 00:33:39 UTC
Still happens with 2.6.12.  I'll try with 2.6.13 which I know has more suspend
patches merged-in.
Comment 9 Shaohua 2005-09-13 21:48:25 UTC

*** This bug has been marked as a duplicate of 4532 ***

Note You need to log in before you can comment on or make changes to this bug.