Bug 39172 - Bug in BCMA: device_unregister causing "NULL pointer dereference at"
Bug in BCMA: device_unregister causing "NULL pointer dereference at"
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 36912
  Show dependency treegraph
 
Reported: 2011-07-11 18:03 UTC by Maciej Rutecki
Modified: 2011-08-08 08:40 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.0-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-07-11 18:03:25 UTC
Subject    : Bug in BCMA: device_unregister causing "NULL pointer dereference at"
Submitter  : Rafał Miłecki <zajec5@gmail.com>
Date       : 2011-07-07 15:25
Message-ID : CACna6rxAKMp-2wqwz4k4S3nTkY_3Qz7=hEZk9F2Zig7T5kp_HA@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=131005233208734&w=2

This entry is being used for tracking a regression from 2.6.39. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2011-08-08 08:11:21 UTC
A patch referencing this bug report has been merged in Linux v3.1-rc1:

commit f76f424353e678f904c6c13f997851efb6077419
Author: Rafał Miłecki <zajec5@gmail.com>
Date:   Fri Jul 22 13:11:04 2011 +0200

    b43: bus: fix memory corruption when setting driver's data
Comment 2 Rafał Miłecki 2011-08-08 08:22:27 UTC
(In reply to comment #1)
> A patch referencing this bug report has been merged in Linux v3.1-rc1:

That's right, thanks for reminding about this bug.

The bug appeared to be b43 one, not bcma one. It means Linux 3.0 is not affected and this bug report can be closed as invalid.
Comment 3 Rafał Miłecki 2011-08-08 08:25:25 UTC
To make it clear:
3.0 contains working bcma
3.1 contains working bcma and working b43

For a short moment there was bug in b43 while development for 3.1 merge window. However it was visible only for those brave enough to drop BROKEN from B43_BCMA.
Comment 4 Florian Mickler 2011-08-08 08:36:03 UTC
Ok.

Note You need to log in before you can comment on or make changes to this bug.