Bug 39052 - .tmp_depmod owned by root after modules_install
.tmp_depmod owned by root after modules_install
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: 36912
  Show dependency treegraph
 
Reported: 2011-07-09 12:12 UTC by Maciej Rutecki
Modified: 2011-08-09 07:54 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.0-rc
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-07-09 12:12:52 UTC
Subject    : .tmp_depmod owned by root after modules_install
Submitter  : Christian Kujau <lists@nerdbynature.de>
Date       : 2011-07-04 9:49
Message-ID : alpine.DEB.2.01.1107040242180.9183@trent.utfs.org
References : http://marc.info/?l=linux-kernel&m=130977296812731&w=2

This entry is being used for tracking a regression from 2.6.39. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Christian Kujau 2011-07-13 22:23:43 UTC
Fix available in http://marc.info/?l=linux-kernel&m=131047080824750&w=2
Comment 2 Florian Mickler 2011-08-09 07:51:46 UTC
Patch merged in v3.0: 

commit 8fc62e59425389a6d48429b9d146223122743435
Author: Michal Marek <mmarek@suse.cz>
Date:   Tue Jul 12 11:54:48 2011 +0200

    kbuild: Do not write to builddir in modules_install

Note You need to log in before you can comment on or make changes to this bug.