Bug 38732 - Linux 3.0-rc5 doesnt boot and hangs at rcu_sched_state ()
Linux 3.0-rc5 doesnt boot and hangs at rcu_sched_state ()
Status: CLOSED CODE_FIX
Product: Process Management
Classification: Unclassified
Component: Scheduler
All Linux
: P1 normal
Assigned To: Ingo Molnar
:
Depends on:
Blocks: 36912
  Show dependency treegraph
 
Reported: 2011-07-03 13:36 UTC by Maciej Rutecki
Modified: 2011-08-14 19:09 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.0-rc5
Tree: Mainline
Regression: Yes


Attachments
Fix for Ravi Kulkarni (1.63 KB, patch)
2011-07-12 21:23 UTC, Paul E. McKenney
Details | Diff

Description Maciej Rutecki 2011-07-03 13:36:47 UTC
Subject    : Linux 3.0-rc5 doesnt boot and hangs at rcu_sched_state ()
Submitter  : RKK <kulkarni.ravi4@gmail.com>
Date       : 2011-06-29 13:38
Message-ID : BANLkTikW6Xk8UMsOHLCnLn7STRzy8RaiJA@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=130935402722869&w=2

This entry is being used for tracking a regression from 2.6.39. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Paul E. McKenney 2011-07-09 16:02:20 UTC
Can you set up the SysRq key as described in Documentation/sysrq.txt?
This might help you get some information about what the system is doing
during the wait time.

My guess is that your kernel is spinning with interrupts disabled, and
that RCU eventually tries to complain about this.  The possible causes
of this are listed in Documentation/RCU/stallwarn.txt.
Comment 2 Florian Mickler 2011-07-12 21:11:15 UTC
Patch: https://lkml.org/lkml/2011/7/10/282
Comment 3 Paul E. McKenney 2011-07-12 21:23:02 UTC
Created attachment 65352 [details]
Fix for Ravi Kulkarni
Comment 4 Paul E. McKenney 2011-07-12 21:24:24 UTC
It looks like I accidentally sent the real patch privately to Ravi, so I linked in the correct patch above.  Florian, please accept my apologies for the confusion.
Comment 5 Florian Mickler 2011-07-12 21:57:26 UTC
No problem at all. It's just book-keeping which will sort itself out later anyway. It should in no way impede on any development/bugfixing. Thx for the note though. 

Ignore-Patch: https://lkml.org/lkml/2011/7/10/282
Patch: https://bugzilla.kernel.org/attachment.cgi?id=65352
Comment 6 Ravi Kumar Kulkarni 2011-07-13 12:31:55 UTC
Hi 
I tested with Peter's patch below
https://lkml.org/lkml/2011/7/12/150 

and Paul's patch https://lkml.org/lkml/2011/7/12/313 
also works fine for me now. thanks.
Comment 7 Rafael J. Wysocki 2011-08-14 19:09:10 UTC
Fixed by commit b0d304172f49061b4ff78f9e2b02719ac69c8a7e .

Note You need to log in before you can comment on or make changes to this bug.