Bug 38722 - 3.0rc3-rc5: usb stops working after resume from suspend to ram
3.0rc3-rc5: usb stops working after resume from suspend to ram
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 7216 36912
  Show dependency treegraph
 
Reported: 2011-07-03 13:25 UTC by Maciej Rutecki
Modified: 2011-07-08 15:07 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.0-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-07-03 13:25:24 UTC
Subject    : 3.0rc3-rc5: usb stops working after resume from suspend to ram
Submitter  : Arkadiusz Miskiewicz <a.miskiewicz@gmail.com>
Date       : 2011-06-29 19:21
Message-ID : 201106292121.34523.a.miskiewicz@gmail.com
References : http://marc.info/?l=linux-kernel&m=130937533419483&w=2

This entry is being used for tracking a regression from 2.6.39. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Arkadiusz Miskiewicz 2011-07-04 08:53:11 UTC
It's regression from 3.0rc4 actually and the guilty commit is below. Reverting it from current git makes usb survive suspend/resume from ram.

commit fccf4e86200b8f5edd9a65da26f150e32ba79808
Author: Sarah Sharp <sarah.a.sharp@linux.intel.com>
Date:   Sun Jun 5 23:22:22 2011 -0700

    USB: Free bandwidth when usb_disable_device is called.
    
    Tanya ran into an issue when trying to switch a UAS device from the BOT
    configuration to the UAS configuration via the bConfigurationValue sysfs
    file.  Before installing the UAS configuration, set_bConfigurationValue()
    calls usb_disable_device().  That function is supposed to remove all host
    controller resources associated with that device, but it leaves some state
    in the xHCI host controller.
    
    Commit 0791971ba8fbc44e4f476079f856335ed45e6324
        usb: allow drivers to use allocated bandwidth until unbound
    added a call to usb_disable_device() in usb_set_configuration(), before
    the xHCI bandwidth functions were invoked.  That commit fixed a bug, but
    also introduced a bug that is triggered when a configured device is
    switched to a new configuration.
    
    usb_disable_device() goes through all the motions of unbinding the drivers
    attached to active interfaces and removing the USB core structures
    associated with those interfaces, but it doesn't actually remove the
    endpoints from the internal xHCI host controller bandwidth structures.
    
    When usb_disable_device() calls usb_disable_endpoint() with reset_hardware
    set to true, the entries in udev->ep_out and udev->ep_in will be set to
    NULL.  Usually, when the USB core installs a new configuration,
    usb_hcd_alloc_bandwidth() will drop all non-NULL endpoints in udev->ep_out
    and udev->ep_in before adding any new endpoints.  However, when the new
    UAS configuration was added, all those entries were null, so none of the
    old endpoints in the BOT configuration were dropped.
    
    The xHCI driver blindly added the UAS configuration endpoints, and some of
    the endpoint addresses overlapped with the old BOT configuration
    endpoints.  This caused the xHCI host to reject the Configure Endpoint
    command.  Now that the xHCI driver code is cleaned up to reject a
    double-add of active endpoints, we need to fix the USB core to properly
    drop old endpoints in usb_disable_device().
    
    If the host controller driver needs bandwidth checking support, make
    usb_disable_device() call usb_disable_endpoint() with
    reset_hardware set to false, drop the endpoints from the xHCI host
    controller, and then call usb_disable_endpoint() again with
    reset_hardware set to true.
    
    The first call to usb_disable_endpoint() will cancel any pending URBs and
    wait on them to be freed in usb_hcd_disable_endpoint(), but will keep the
    pointers in udev->ep_out and udev->ep in intact.  Then
    usb_hcd_alloc_bandwidth() will use those pointers to know which endpoints
    to drop.
    
    The final call to usb_disable_endpoint() will do two things:
    
    1. It will call usb_hcd_disable_endpoint() again, which should be harmless
    since the ep->urb_list should be empty after the first call to
    usb_disable_endpoint() returns.
    
    2. It will set the entries in udev->ep_out and udev->ep in to NULL, and call
    usb_hcd_disable_endpoint().  That call will have no effect, since the xHCI
    driver doesn't set the endpoint_disable function pointer.
    
    Note that usb_disable_device() will now need to be called with
    hcd->bandwidth_mutex held.
    
    This should be backported to kernels as old as 2.6.32.
    
    Signed-off-by: Sarah Sharp <sarah.a.sharp@linux.intel.com>
    Reported-by: Tanya Brokhman <tlinder@codeaurora.org>
    Cc: ablay@codeaurora.org
    Cc: Alan Stern <stern@rowland.harvard.edu>
    Cc: stable@kernel.org
Comment 2 Florian Mickler 2011-07-08 15:06:59 UTC
Should be fixed in 3.0-rc7 / final 3.0 by the patches:

commit e534c5b831c8b8e9f5edee5c8a37753c808b80dc
Author: Alan Stern <stern@rowland.harvard.edu>
Date:   Fri Jul 1 16:43:02 2011 -0400

    USB: fix regression occurring during device removal


and 

commit ca5c485f55d326d9a23e4badd05890148aa53f74
Author: Alan Stern <stern@rowland.harvard.edu>
Date:   Wed Jul 6 17:03:45 2011 -0400

    USB: additional regression fix for device removal

Note You need to log in before you can comment on or make changes to this bug.