Bug 38702 - 3.0.0-rc4-git6 - INFO: possible circular locking dependency detected - (&rdev->mtx){+.+.+.}, at: [<ffffffffa00e27e0>] cfg80211_netdev_notifier_call+0x275/0x4ff [cfg80211]
3.0.0-rc4-git6 - INFO: possible circular locking dependency detected - (&rdev...
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 36912
  Show dependency treegraph
 
Reported: 2011-07-02 21:35 UTC by Maciej Rutecki
Modified: 2011-07-10 11:13 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.0.0-rc4-git6
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-07-02 21:35:07 UTC
Subject    : 3.0.0-rc4-git6 - INFO: possible circular locking dependency detected - (&rdev->mtx){+.+.+.}, at: [<ffffffffa00e27e0>] cfg80211_netdev_notifier_call+0x275/0x4ff [cfg80211]
Submitter  : Miles Lane <miles.lane@gmail.com>
Date       : 2011-06-26 21:54
Message-ID : BANLkTikztsFnPkJZ7VxRC-zsitwCCvVmeg@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=130912559804336&w=2

This entry is being used for tracking a regression from 2.6.39. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2011-07-10 11:12:05 UTC
On Sunday, July 10, 2011, Johannes Berg wrote:
> On Sun, 2011-07-10 at 12:19 +0200, Rafael J. Wysocki wrote:
> 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=38702
> > Subject		: 3.0.0-rc4-git6 - INFO: possible circular locking dependency detected - (&rdev->mtx){+.+.+.}, at: [<ffffffffa00e27e0>] cfg80211_netdev_notifier_call+0x275/0x4ff [cfg80211]
> > Submitter	: Miles Lane <miles.lane@gmail.com>
> > Date		: 2011-06-26 21:54 (15 days old)
> 
> Should be fixed by c10841ca722a0bc960dc541c51582773f9a24f98 which was
> part of John's latest pull request and is in net-2.6 now on its way up.

Note You need to log in before you can comment on or make changes to this bug.