Bug 38612 - Boot time warnings in APIC
Boot time warnings in APIC
Status: CLOSED UNREPRODUCIBLE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks: 36912
  Show dependency treegraph
 
Reported: 2011-07-01 06:44 UTC by Bill Huey
Modified: 2011-08-15 09:24 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.0.0-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Bill Huey 2011-07-01 06:44:45 UTC
Jun 30 03:45:08 finfin kernel: [    0.110000] ------------[ cut here ]------------
Jun 30 03:45:08 finfin kernel: [    0.110000] WARNING: at arch/x86/kernel/apic/apic.c:1298 setup_local_APIC+0x16c/0x225()
Jun 30 03:45:08 finfin kernel: [    0.110000] Hardware name: MS-7376
Jun 30 03:45:08 finfin kernel: [    0.110000] Modules linked in:
Jun 30 03:45:08 finfin kernel: [    0.110000] Pid: 1, comm: swapper Not tainted 3.0.0-rc5-custom #1
Jun 30 03:45:08 finfin kernel: [    0.110000] Call Trace:
Jun 30 03:45:08 finfin kernel: [    0.110000]  [<ffffffff8106086f>] warn_slowpath_common+0x7f/0xc0
Jun 30 03:45:08 finfin kernel: [    0.110000]  [<ffffffff810608ca>] warn_slowpath_null+0x1a/0x20
Jun 30 03:45:08 finfin kernel: [    0.110000]  [<ffffffff815e97aa>] setup_local_APIC+0x16c/0x225
Jun 30 03:45:08 finfin kernel: [    0.110000]  [<ffffffff81eb7160>] native_smp_prepare_cpus+0x263/0x311
Jun 30 03:45:08 finfin kernel: [    0.110000]  [<ffffffff81ea9cb0>] kernel_init+0x77/0x14b
Jun 30 03:45:08 finfin kernel: [    0.110000]  [<ffffffff815fb3e4>] kernel_thread_helper+0x4/0x10
Jun 30 03:45:08 finfin kernel: [    0.110000]  [<ffffffff81ea9c39>] ? start_kernel+0x3e2/0x3e2
Jun 30 03:45:08 finfin kernel: [    0.110000]  [<ffffffff815fb3e0>] ? gs_change+0x13/0x13
Jun 30 03:45:08 finfin kernel: [    0.110000] ---[ end trace a7919e7f17c0a725 ]---


Jun 30 03:45:08 finfin kernel: [    0.050000] ------------[ cut here ]------------
Jun 30 03:45:08 finfin kernel: [    0.050000] WARNING: at arch/x86/kernel/apic/apic.c:1298 setup_local_APIC+0x16c/0x225()
Jun 30 03:45:08 finfin kernel: [    0.050000] Hardware name: MS-7376
Jun 30 03:45:08 finfin kernel: [    0.050000] Modules linked in:
Jun 30 03:45:08 finfin kernel: [    0.050000] Pid: 0, comm: kworker/0:0 Tainted: G        W   3.0.0-rc5-custom #1
Jun 30 03:45:08 finfin kernel: [    0.050000] Call Trace:
Jun 30 03:45:08 finfin kernel: [    0.050000]  [<ffffffff8106086f>] warn_slowpath_common+0x7f/0xc0
Jun 30 03:45:08 finfin kernel: [    0.050000]  [<ffffffff810608ca>] warn_slowpath_null+0x1a/0x20
Jun 30 03:45:08 finfin kernel: [    0.050000]  [<ffffffff815e97aa>] setup_local_APIC+0x16c/0x225
Jun 30 03:45:08 finfin kernel: [    0.050000]  [<ffffffff815e8fd9>] start_secondary+0xca/0x1e7
Jun 30 03:45:08 finfin kernel: [    0.050000] ---[ end trace a7919e7f17c0a726 ]---



Jun 30 03:45:08 finfin kernel: [    0.050000] ------------[ cut here ]------------
Jun 30 03:45:08 finfin kernel: [    0.050000] WARNING: at arch/x86/kernel/apic/apic.c:1298 setup_local_APIC+0x16c/0x225()
Jun 30 03:45:08 finfin kernel: [    0.050000] Hardware name: MS-7376
Jun 30 03:45:08 finfin kernel: [    0.050000] Modules linked in:
Jun 30 03:45:08 finfin kernel: [    0.050000] Pid: 0, comm: kworker/0:1 Tainted: G        W   3.0.0-rc5-custom #1
Jun 30 03:45:08 finfin kernel: [    0.050000] Call Trace:
Jun 30 03:45:08 finfin kernel: [    0.050000]  [<ffffffff8106086f>] warn_slowpath_common+0x7f/0xc0
Jun 30 03:45:08 finfin kernel: [    0.050000]  [<ffffffff810608ca>] warn_slowpath_null+0x1a/0x20
Jun 30 03:45:08 finfin kernel: [    0.050000]  [<ffffffff815e97aa>] setup_local_APIC+0x16c/0x225
Jun 30 03:45:08 finfin kernel: [    0.050000]  [<ffffffff815e8fd9>] start_secondary+0xca/0x1e7
Jun 30 03:45:08 finfin kernel: [    0.050000] ---[ end trace a7919e7f17c0a727 ]---
Jun 30 03:45:08 finfin kernel: [    0.460000] lockdep: fixing up alternatives.
Jun 30 03:45:08 finfin kernel: [    0.460000]  #3 Ok.
Jun 30 03:45:08 finfin kernel: [    0.460000] smpboot cpu 3: start_ip = 9a000
Jun 30 03:45:08 finfin kernel: [    0.050000] ------------[ cut here ]------------
Jun 30 03:45:08 finfin kernel: [    0.050000] WARNING: at arch/x86/kernel/apic/apic.c:1298 setup_local_APIC+0x16c/0x225()
Jun 30 03:45:08 finfin kernel: [    0.050000] Hardware name: MS-7376
Jun 30 03:45:08 finfin kernel: [    0.050000] Modules linked in:
Jun 30 03:45:08 finfin kernel: [    0.050000] Pid: 0, comm: kworker/0:1 Tainted: G        W   3.0.0-rc5-custom #1
Jun 30 03:45:08 finfin kernel: [    0.050000] Call Trace:
Jun 30 03:45:08 finfin kernel: [    0.050000]  [<ffffffff8106086f>] warn_slowpath_common+0x7f/0xc0
Jun 30 03:45:08 finfin kernel: [    0.050000]  [<ffffffff810608ca>] warn_slowpath_null+0x1a/0x20
Jun 30 03:45:08 finfin kernel: [    0.050000]  [<ffffffff815e97aa>] setup_local_APIC+0x16c/0x225
Jun 30 03:45:08 finfin kernel: [    0.050000]  [<ffffffff815e8fd9>] start_secondary+0xca/0x1e7
Jun 30 03:45:08 finfin kernel: [    0.050000] ---[ end trace a7919e7f17c0a728 ]---
Comment 1 Andrew Morton 2011-07-01 06:47:02 UTC
A regression since 2.6.39, I assume?
Comment 2 Bill Huey 2011-07-01 06:49:52 UTC
Quite possibly yes. I've been getting a lot of random kernel crashes under Ubuntu Natty as well with 2.6.38 so I'm not sure if it's the general state of the kernel or possibly dying hardware.
Comment 3 Rafael J. Wysocki 2011-08-15 09:23:16 UTC
On Sunday, August 14, 2011, Bill Huey (hui) wrote:
> It seemed like a hardware problem so change the state of the bug. I'll
> keep you folks update if I see it again.

Note You need to log in before you can comment on or make changes to this bug.