Bug 38592 - Booting Radeon KMS In Newer Kernels Causes Kernel Output To Be In The Center Of Screen
Summary: Booting Radeon KMS In Newer Kernels Causes Kernel Output To Be In The Center ...
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-01 00:15 UTC by MM
Modified: 2013-12-23 14:03 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.37
Tree: Mainline
Regression: No


Attachments
lspci -vvv (20.76 KB, text/plain)
2011-07-01 00:16 UTC, MM
Details
cat /proc/cpuinfo (704 bytes, text/plain)
2011-07-01 00:16 UTC, MM
Details
cat /proc/iomem (1.90 KB, text/plain)
2011-07-01 00:17 UTC, MM
Details
cat /proc/ioports (1.25 KB, text/plain)
2011-07-01 00:17 UTC, MM
Details
cat /proc/modules (3.80 KB, text/plain)
2011-07-01 00:18 UTC, MM
Details
cat /proc/scsi (336 bytes, text/plain)
2011-07-01 00:19 UTC, MM
Details
cat /proc/version (107 bytes, text/plain)
2011-07-01 00:20 UTC, MM
Details
Xorg Log (23.93 KB, text/plain)
2011-07-03 22:41 UTC, MM
Details
dmesg (32.23 KB, text/plain)
2011-07-03 22:41 UTC, MM
Details
lilo.conf (2.28 KB, text/plain)
2011-07-03 22:43 UTC, MM
Details
Xorg-37.6 (23.33 KB, text/plain)
2011-07-04 04:24 UTC, MM
Details
dmesg-37.6 (31.97 KB, application/octet-stream)
2011-07-04 04:25 UTC, MM
Details
lilo-37.6 (2.44 KB, text/plain)
2011-07-04 04:27 UTC, MM
Details
dmesg-37.6-(text) (31.97 KB, text/plain)
2011-07-04 04:31 UTC, MM
Details

Description MM 2011-07-01 00:15:16 UTC
I'm running Slackware 13.1 x86 with 2.6.36.4 and I have an ATI HD3200 chip on a laptop so I compiled the kernel with Radeon KMS.

After Lilo boots I get the console messages at like 640x480 for 1-2 secs then the KMS kicks in and all the console messages like they should go down on the far left side of the screen with Tux sitting in the top left.

But if I use a .37 or .38 or .39 kernel when the KMS kicks in the text appears for like the first paragraph of messages in the center of my screen then afterwards on the left like it should. This has never happened in any of the .36 kernels and I don't get why, and I filed a bug report a few months back when .37 came out but never heard anything about it, so I'm filing this over again.

Anyone have any idea why the text when it's first appearing when KMS kicks in for the .37 .38 .39 kernels is in the center of the screen then moving over to the left instead of just starting out on the left side like it should?

Here's my kernel config for 2.6.36.4

http://pastebin.com/Cxhadb0K
Comment 1 MM 2011-07-01 00:16:11 UTC
Created attachment 64122 [details]
lspci -vvv
Comment 2 MM 2011-07-01 00:16:45 UTC
Created attachment 64132 [details]
cat /proc/cpuinfo
Comment 3 MM 2011-07-01 00:17:12 UTC
Created attachment 64142 [details]
cat /proc/iomem
Comment 4 MM 2011-07-01 00:17:44 UTC
Created attachment 64152 [details]
cat /proc/ioports
Comment 5 MM 2011-07-01 00:18:09 UTC
Created attachment 64162 [details]
cat /proc/modules
Comment 6 MM 2011-07-01 00:19:12 UTC
Created attachment 64172 [details]
cat /proc/scsi
Comment 7 MM 2011-07-01 00:20:24 UTC
Created attachment 64182 [details]
cat /proc/version
Comment 8 Alex Deucher 2011-07-02 14:43:36 UTC
Please attach your dmesg output and Xorg log if you are using X.  Also, what type of monitor and which connector on the card are you using?  Also what does your kernel command line look like?
Comment 9 MM 2011-07-03 22:41:20 UTC
Created attachment 64482 [details]
Xorg Log
Comment 10 MM 2011-07-03 22:41:55 UTC
Created attachment 64492 [details]
dmesg
Comment 11 MM 2011-07-03 22:43:03 UTC
Created attachment 64502 [details]
lilo.conf
Comment 12 MM 2011-07-03 22:44:14 UTC
I mentioned in the report when I opened it that this is an ATI HD3200 chip on a
laptop.

I've attached 3 logs...


THANKS
Comment 13 MM 2011-07-04 04:23:08 UTC
Sorry all the info above is with the 36.4 kernel I'm attaching new logs marked for the 37.6 kernel...


THANKS
Comment 14 MM 2011-07-04 04:24:02 UTC
Created attachment 64512 [details]
Xorg-37.6
Comment 15 MM 2011-07-04 04:25:34 UTC
Created attachment 64522 [details]
dmesg-37.6
Comment 16 MM 2011-07-04 04:27:18 UTC
Created attachment 64532 [details]
lilo-37.6
Comment 17 MM 2011-07-04 04:31:09 UTC
Created attachment 64542 [details]
dmesg-37.6-(text)
Comment 18 Alan 2013-12-23 14:03:17 UTC
If this is still present in modern kernels please update the bug

Note You need to log in before you can comment on or make changes to this bug.