Bug 38542 - single-request-reopen option needs to be documented in resolv.conf
single-request-reopen option needs to be documented in resolv.conf
Status: RESOLVED CODE_FIX
Product: Documentation
Classification: Unclassified
Component: man-pages
All Linux
: P1 normal
Assigned To: documentation_man-pages@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-29 20:05 UTC by Erinn Looney-Triggs
Modified: 2012-04-23 12:15 UTC (History)
1 user (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments

Description Erinn Looney-Triggs 2011-06-29 20:05:34 UTC
This option was introduced here: http://sourceware.org/ml/libc-alpha/2009-10/msg00063.html

However, there appears to be no documentation for it. Folks are going to be looking for this as they deploy systems behind firewalls and end up with delays due to DNS, see here: http://www.linuxquestions.org/questions/showthread.php?p=4399340#post4399340

So if you could please document the option, I at least would greatly appreciate it.

Thanks,

-Erinn
Comment 1 Michael Kerrisk 2012-04-23 12:15:36 UTC
Patch from Petr Baudis applied for man-pages-3.40:

--- a/man5/resolv.conf.5
+++ b/man5/resolv.conf.5
@@ -231,6 +231,19 @@ sets
 in
 .IR _res.options .
 This enables support for the DNS extensions described in RFC\ 2671.
+.TP
+.BR single-request " (since glibc 2.10)"
+sets
+.BR RES_SNGLKUP
+in
+.IR _res.options .
+By default, glibc performs IPv4 and IPv6 lookups in parallel since
+version 2.9.
+Some appliance DNS servers
+cannot handle these queries properly and make the requests time out.
+This option disables the behavior and makes glibc perform the IPv6
+and IPv4 requests sequentially (at the cost of some slowdown of the
+resolving process).
 .RE
 .LP
 The \fIdomain\fP and \fIsearch\fP keywords are mutually exclusive.

Note You need to log in before you can comment on or make changes to this bug.