Bug 3842 - Unable to compile uniprocessor kernel with acpi-20041105-26-stable-release
Summary: Unable to compile uniprocessor kernel with acpi-20041105-26-stable-release
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: i386 Linux
: P2 blocking
Assignee: acpi_other
URL:
Keywords:
: 3843 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-11-30 04:56 UTC by Oleg I. Vdovikin
Modified: 2004-12-01 18:51 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.9
Tree: Mainline
Regression: ---


Attachments
FC3 kernel config (13.14 KB, application/x-gzip-compressed)
2004-12-01 03:07 UTC, Oleg I. Vdovikin
Details

Description Oleg I. Vdovikin 2004-11-30 04:56:20 UTC
Distribution: Fedora Core 3
Hardware Environment: Any
Software Environment: gcc-3.4.2
Problem Description: Unable to compile uniprocessor kernel with acpi-20041105-
26-stable-release patch, with IO APIC disabled

Steps to reproduce:
Try to compile 2.6.9 kernel, patched with acpi-20041105-26-stable-release with 
IO APIC disabled. Compilation stops and the following error is displayed:

  CC      arch/i386/kernel/acpi/boot.o
arch/i386/kernel/acpi/boot.c: In function `acpi_boot_init':
arch/i386/kernel/acpi/boot.c:821: warning: implicit declaration of function 
`check_acpi_pci'
  CC      arch/i386/kernel/acpi/earlyquirk.o
arch/i386/kernel/acpi/earlyquirk.c: In function `check_bridge':
arch/i386/kernel/acpi/earlyquirk.c:16: error: `acpi_skip_timer_override' 
undeclared (first use in this function)
arch/i386/kernel/acpi/earlyquirk.c:16: error: (Each undeclared identifier is 
reported only once
arch/i386/kernel/acpi/earlyquirk.c:16: error: for each function it appears in.)
make[2]: *** [arch/i386/kernel/acpi/earlyquirk.o] Error 1
make[1]: *** [arch/i386/kernel/acpi] Error 2
make: *** [arch/i386/kernel] Error 2

Examined include/asm/acpi.h and it looks like acpi_skip_timer_override is 
defined only then CONFIG_X86_IO_APIC option specified. Probably check_bridge 
should not be used then.
Comment 1 Len Brown 2004-11-30 22:54:47 UTC
I build several UP kernels without IO_APIC and don't see any errors. 
 
arch/i386/kernel/acpi/earlyquirk.c 
is included in the build only if CONFIG_X86_IOAPIC 
so I don't see how the errors above resulted if that was not in the config. 
 
Pleaes do a make clean before building -- it may be that 
some dependencies in the build were not cleared. 
 
If you still have a problem with a clean build of the latest patch, 
please re-open and attach the failing .config. 
 
Comment 2 Len Brown 2004-11-30 23:51:51 UTC
*** Bug 3843 has been marked as a duplicate of this bug. ***
Comment 3 Oleg I. Vdovikin 2004-12-01 02:40:30 UTC
Len, I've checked patch - it does include earlyquirk.o then CONFIG_ACPI_BOOT is 
enabled. Right? And it does not check for IO APIC.

diff -Nru a/arch/i386/kernel/acpi/Makefile b/arch/i386/kernel/acpi/Makefile
--- a/arch/i386/kernel/acpi/Makefile    2004-11-23 01:26:22 -05:00
+++ b/arch/i386/kernel/acpi/Makefile    2004-11-23 01:26:22 -05:00
@@ -1,3 +1,3 @@
-obj-$(CONFIG_ACPI_BOOT)                := boot.o
+obj-$(CONFIG_ACPI_BOOT)                := boot.o earlyquirk.o
Comment 4 Oleg I. Vdovikin 2004-12-01 03:07:58 UTC
Created attachment 4184 [details]
FC3 kernel config

Kernel config used for build
Comment 5 Len Brown 2004-12-01 18:51:26 UTC
please re-download the patch, it has been updated with the fix.
re-open if you have problems with the new one.

thanks,
-len

Note You need to log in before you can comment on or make changes to this bug.