Bug 38232 - kernel bug at drivers/gpu/drm/ttm/ttm_bo.c:272
kernel bug at drivers/gpu/drm/ttm/ttm_bo.c:272
Status: CLOSED DUPLICATE of bug 32402
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
http://i53.tinypic.com/1zwdxqh.jpg
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-06-25 09:27 UTC by lukenshiro
Modified: 2011-06-27 22:12 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.39.*
Tree: Mainline
Regression: Yes


Attachments
.config file for 2.6.39.2 (127.68 KB, application/octet-stream)
2011-06-25 11:01 UTC, lukenshiro
Details

Description lukenshiro 2011-06-25 09:27:36 UTC
I have a kernel panic using a Radeon HD4350 (RV710) with kernel 2.6.39.2, in Slackware "current" (CPU AMD Phenom, x86_64 non multilib, gcc 4.5.3, glibc 2.13, make 3.82, binutils 2.21.51.0.6, libdrm 2.4.25, ati xorg driver 6.14.1), after some (about 2 hours) of use.
I have had similar panics also in 2.6.39 and 2.6.39.1 before (but I couldn't do a transcription of correlative messages).
In url I put the most clear screen snapshot I've taken with a digital camera (i did other ones but unfortunately they are not of so good quality).
Messages/syslog log files are not really useful. If you need other infos please let me know.

Another photo is on:
http://i53.tinypic.com/2jfhax.jpg
Comment 1 lukenshiro 2011-06-25 11:01:53 UTC
Created attachment 63472 [details]
.config file for 2.6.39.2
Comment 2 Alex Deucher 2011-06-25 16:28:19 UTC
Looks like a duplicate of bug 32402.
Comment 3 lukenshiro 2011-06-26 12:57:58 UTC
Sorry, after testing (with success) proposed fix by D.Airlie https://bugzilla.kernel.org/attachment.cgi?id=59942 I can say it definitely is a duplicate of 32402.

That patch is already present in version 3.0-rc3; any chances for it to be applied also in future 2.6.39.x kernels?

*** This bug has been marked as a duplicate of bug 32402 ***

Note You need to log in before you can comment on or make changes to this bug.